HDU 1789 Doing Homework again(排序,DP)

Doing Homework again

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2969    Accepted Submission(s): 1707

Problem Description Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.  

 

Input The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.

Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.  

 

Output For each test case, you should output the smallest total reduced score, one line per test case.  

 

Sample Input 3 3 3 3 3 10 5 1 3 1 3 1 6 2 3 7 1 4 6 4 2 4 3 3 2 1 7 6 5 4  

 

Sample Output 0 3 5  

 

Author lcy  

 

Source
2007省赛集训队练习赛(10)_以此感谢DOOMIII  

 

Recommend lcy       先按照扣分从大到小排序,分数相同则按照截止日期从小到大排序。。   然后按顺序,从截止日期开始往前找没有占用掉的时间。 如果找不到了,则加到罚分里面   具体看程序。。

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

const int MAXN=1010;

struct Node
{
    int d,s;
}node[MAXN];

bool used[10000];

bool cmp(Node a,Node b)
{
    if(a.s==b.s)
    {
        return a.d<b.d;
    }    
    return a.s>b.s;
}        

int main()
{
    int T;
    int n;
    int j;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        for(int i=0;i<n;i++) scanf("%d",&node[i].d);
        for(int i=0;i<n;i++) scanf("%d",&node[i].s);
        sort(node,node+n,cmp);
        memset(used,false,sizeof(used));
        int ans=0;
        for(int i=0;i<n;i++)
        {
            for(j=node[i].d;j>0;j--)
            {
                if(!used[j])
                {
                    used[j]=true;
                    break;
                }    
            }    
            if(j==0)
              ans+=node[i].s;
        }    
        printf("%d\n",ans);
    }    
    return 0;
}    

 

 

    原文作者:算法小白
    原文地址: https://www.cnblogs.com/kuangbin/archive/2012/08/04/2623270.html
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞