[编程之美-02]字符串的包含问题

[版权说明]
编程之美系列算法题集参考:
左程云 著《程序员代码面试指南IT名企算法与数据结构题目最优解》
July 著《编程之法面试和算法心得》
何海涛 著《剑指offer》
微软编程之美小组 著《编程之美》
部分题目摘选PAT、HDOJ、POJ以及各大互联网公司Google,BAT等面试题集。

博主采用C/C++语言实现(有些题目的解法进行优化)。希望编程之美系列博文没有侵犯版权!(若侵权,请联系我,邮箱:1511082629@nbu.edu.cn )
欢迎大家转载分享,编程之美系列算法题集,会不定期更新。鉴于博主本人水平有限,如有问题。恳请批评指正!

[Problem Description]
给定一长字符串 a 和一段字符串 b 。请问, 如何最快的判断出短字符串 b 中的所有字符是否都在长字符串 a 中。

[Sample Input]
ABCD BAD
ABCD BCE
ABCD AA

[Sample Output]
true
false
true

基本解法:我们遍历字符串b,依次判断b中的每个字符是不是的都在字符串a中。

代码如下:

#include<iostream>
#include<string>
using namespace std; 

bool stringContain(string &a, string &b);

int main()
{
    string a, b;
    while(cin>>a>>b)
    {
        if(stringContain(a, b))
            cout<< "true" << endl;
        else
            cout<< "false" << endl;
    }
    return 0;   
} 

bool stringContain(string &a, string &b)
{
    for(int i = 0; i < b.length(); i ++)
    {
        if(a.find(b[i]) > b.length())
            return false;
    }
    return true;
}

时间复杂度:O(m*n), 空间复杂度:O(1)

高效算法:思考角度,我们都知道ASCII码一共有127个,而题目所说的字符串都是由ASCII码组合而成。首先遍历字符串a,将a中每个字符转化为int类型(作为数组角码)。并开辟数组大小为128的bool类型count数组。count[a[i]] = true.接着去遍历字符串b,依次判断每个字符是否count[b[i]] == true.

代码如下:

#include<iostream>
#include<string>
#include<string.h>
using namespace std; 

bool stringContain(string &a, string &b);

int main()
{
    string a, b;
    while(cin>>a>>b)
    {
        if(stringContain(a, b))
            cout<< "true" << endl;
        else
            cout<< "false" << endl;
    }
    return 0;   
} 

bool stringContain(string &a, string &b)
{
    bool count[128];
    memset(count, false, sizeof(count));

    for(int i = 0; i < a.length(); i ++)
    {
        count[a[i]] = true;
    }

    for(int i = 0; i < b.length(); i ++)
    {
        if(count[b[i]] == false)
            return false;
    }
    return true; 
}

时间复杂度:O(m+n), 空间复杂度:128B

    原文作者:caicaiatnbu
    原文地址: https://blog.csdn.net/caicaiatnbu/article/details/71493160
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞