【宿舍菜鸟们的ACM解题笔记】487-3279

题目来源

北大ACM,题目ID 1002,难度 初级。

题目简介

Description

Businesses like to have memorable telephone numbers. One way to make a telephone number memorable is to have it spell a memorable word or phrase. For example, you can call the University of Waterloo by dialing the memorable TUT-GLOP. Sometimes only part of the number is used to spell a word. When you get back to your hotel tonight you can order a pizza from Gino’s by dialing 310-GINO. Another way to make a telephone number memorable is to group the digits in a memorable way. You could order your pizza from Pizza Hut by calling their “three tens” number 3-10-10-10. 

The standard form of a telephone number is seven decimal digits with a hyphen between the third and fourth digits (e.g. 888-1200). The keypad of a phone supplies the mapping of letters to numbers, as follows: 

A, B, and C map to 2 

D, E, and F map to 3 

G, H, and I map to 4 

J, K, and L map to 5 

M, N, and O map to 6 

P, R, and S map to 7 

T, U, and V map to 8 

W, X, and Y map to 9 

There is no mapping for Q or Z. Hyphens are not dialed, and can be added and removed as necessary. The standard form of TUT-GLOP is 888-4567, the standard form of 310-GINO is 310-4466, and the standard form of 3-10-10-10 is 310-1010. 

Two telephone numbers are equivalent if they have the same standard form. (They dial the same number.) 

Your company is compiling a directory of telephone numbers from local businesses. As part of the quality control process you want to check that no two (or more) businesses in the directory have the same telephone number. 

Input

The input will consist of one case. The first line of the input specifies the number of telephone numbers in the directory (up to 100,000) as a positive integer alone on the line. The remaining lines list the telephone numbers in the directory, with each number alone on a line. Each telephone number consists of a string composed of decimal digits, uppercase letters (excluding Q and Z) and hyphens. Exactly seven of the characters in the string will be digits or letters. 

Output

Generate a line of output for each telephone number that appears more than once in any form. The line should give the telephone number in standard form, followed by a space, followed by the number of times the telephone number appears in the directory. Arrange the output lines by telephone number in ascending lexicographical order. If there are no duplicates in the input print the line: 

No duplicates. 

Sample Input

12
4873279
ITS-EASY
888-4567
3-10-10-10
888-GLOP
TUT-GLOP
967-11-11
310-GINO
F101010
888-1200
-4-8-7-3-2-7-9-
487-3279

Sample Output

310-1010 2
487-3279 4
888-4567 3

题目解答

1. 理解题意

  • 题意:

输入一组电话号码,有的用数字表示,有的用字母表示,有的既有数字也有大写字母,有的有“-”。那么我们的工作就是利用你的火眼金睛,找出每个电话号码出现的次数,并对出现次数超过1次的电话号码,以字典升序的方式输出。
例如310-1010,总共出现了两次3-10-10-10-10和F10101010。

  • 输入:

12~本次需要输入电话号码的个数
下面12行表示输入的12个电话号码

  • 输出:

出现次数超过1次的电话号码以及它们相应出现的次数


2. 解答
这个题目技术上的难度为0,只需要理解题意一步一步来就是了。代码思想主线是定义一个map,将电话号码作为键索引,每个电话号码出现的次数为键值。利用map主要可以使用map的诸多优点,比如它可以自动的帮我们统计每个电话号码出现的次数,再比如它可以不会吹灰之力的帮我们获取以字典升序方式的输出。关于map可参考c++ premier。


主要工作在于键索引的获取,为了获得干净的键索引,我们需要

  • 把大写字母转换成题目中给出的数字;
  • 把-去掉

除此之外,见代码。

完整代码

#include <stdlib.h>
#include <iostream>
#include <string>
#include <map>


using namespace std;

int main()
{
	int a[26] = {0};
	int numberBit = 2;
	int stringCnt = 0;
	int phoneNum = 0;
	int resultFlag = 0;
	int index = 0;
	string  phoneString;
	string phoneOnlyNumbers;
	string hyphens = "-"; 
	std::map <string, int> stringLinkNumber;

	/* 1.初始化 */
	for (int i = 0; i < 26; i++)
	{
		/* 如果是Q或者Z的话,没有对应的数字键 */
		if ((16 == i) || ((25 == i)))
		{
			continue;
		}
		else
		{
			a[i] = numberBit;
			stringCnt++;
			if (3 == stringCnt)
			{
				numberBit++;
				stringCnt = 0;
				continue;
			}
		}
	}

	/* 2.获取输入信息 */
	cin >> phoneNum;
	if (phoneNum > 100000)
	{
		cout << "No duplicates." << endl;
	}

	for (int i = 0; i < phoneNum; i++)
	{
		phoneString == "";
		phoneOnlyNumbers = "";

		/* 2.1 将电话号码读入到phoneString中 */

		cin >> phoneString;
		for (int j = 0; j < phoneString.size(); j++)
		{
			/* 如果碰到了“-”号,那么略过 */
			if ('-' == phoneString[j])
			{
				continue;
			}
			else
			{
				/* 如果含有大写字母的话,则进行转换 */
				if ((phoneString[j] >= 'A') && ((phoneString[j] <= 'Z')))
				{
					index = phoneString[j] - 'A';
					phoneOnlyNumbers += a[index] + '0';
				}
				else
				{
					/* 既不含有字母,又不含有划线,那么直接拼接 */
					phoneOnlyNumbers += phoneString[j];
				}
			}
		}

		phoneOnlyNumbers.insert(3,"-");

		/* 2.2 将只含有数字的电话号码字符串赋值给map的下标,并将该电话号码出现的次数自加 */
		++stringLinkNumber[phoneOnlyNumbers];
	}

	/* 3. 将map中的电话号码按照字典顺序进行排序 */
	std::map<string,int>::iterator it = stringLinkNumber.begin();
	for (; it != stringLinkNumber.end(); it++)
	{
		std::pair<string,int> _p = *it;
		if (1 < _p.second)
		{
			std::cout <<_p.first<<" "<< _p.second<< endl;
			resultFlag = 1;
		}
	}
	if (0 == resultFlag)
	{
		cout << "No duplicates." << endl;
	}
	return 0;
}

总结及该有的收获

通过这个题目,可以学习map相关知识和c++中string的内容。













    原文作者:爱上健身的菇凉
    原文地址: https://blog.csdn.net/XIAXIA__/article/details/40793357
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞