动态规划 || 多维

A Mini Locomotive

A train has a locomotive that pulls the train with its many passenger coaches. If the locomotive breaks down, there is no way to pull the train. Therefore, the office of railroads decided to distribute three mini locomotives to each station. A mini locomotive can pull only a few passenger coaches. If a locomotive breaks down, three mini locomotives cannot pull all passenger coaches. So, the office of railroads made a decision as follows: 

1. Set the number of maximum passenger coaches a mini locomotive can pull, and a mini locomotive will not pull over the number. The number is same for all three locomotives. 

2. With three mini locomotives, let them transport the maximum number of passengers to destination. The office already knew the number of passengers in each passenger coach, and no passengers are allowed to move between coaches. 

3. Each mini locomotive pulls consecutive passenger coaches. Right after the locomotive, passenger coaches have numbers starting from 1. 

For example, assume there are 7 passenger coaches, and one mini locomotive can pull a maximum of 2 passenger coaches. The number of passengers in the passenger coaches, in order from 1 to 7, is 35, 40, 50, 10, 30, 45, and 60. 

If three mini locomotives pull passenger coaches 1-2, 3-4, and 6-7, they can transport 240 passengers. In this example, three mini locomotives cannot transport more than 240 passengers. 

Given the number of passenger coaches, the number of passengers in each passenger coach, and the maximum number of passenger coaches which can be pulled by a mini locomotive, write a program to find the maximum number of passengers which can be transported by the three mini locomotives. 

Input

The first line of the input contains a single integer t (1 <= t <= 11), the number of test cases, followed by the input data for each test case. The input for each test case will be as follows: 

The first line of the input file contains the number of passenger coaches, which will not exceed 50,000. The second line contains a list of space separated integers giving the number of passengers in each coach, such that the i th number of in this line is the number of passengers in coach i. No coach holds more than 100 passengers. The third line contains the maximum number of passenger coaches which can be pulled by a single mini locomotive. This number will not exceed 1/3 of the number of passenger coaches. 

Output

There should be one line per test case, containing the maximum number of passengers which can be transported by the three mini locomotives.

Sample Input

1

7

35 40 50 10 30 45 60

2

Sample Output

240

一个数列,n个数,找三个 k个连续数的子数列,使其和最大。

s[i]:以a[i]结尾的长度为k的子数列的和

dp[i][j]:表示以a[j]结尾的数列中已经找到i个,且最大的和保存在dp[i][j]中。

dp[i][j]=max(dp[i][j-1],dp[i-1][j-k]+s[j]);


#include<stdio.h>
#include<memory.h>
#include<iostream>
#include<algorithm>
#include<vector>
#include<algorithm>
#include<math.h>
#include<set>
#include<queue>
using namespace std;
typedef long long ll;
int T;
int n,k;
int a[50005];
int s[50005];
int dp[4][50005];

int main(){
	scanf("%d",&T);
	while(T--){
		scanf("%d",&n);
		for(int i=1;i<=n;i++){
			scanf("%d",&a[i]);
		}
		scanf("%d",&k);
		for(int i=1;i<=n;i++){
			if(i>k){
				s[i]=s[i-1]+a[i]-a[i-k];
			}
			else{
				s[i]=s[i-1]+a[i];
			}
		}
		memset(dp,0,sizeof(dp));
		for(int i=1;i<=3;i++){
			for(int j=i*k;j<=n;j++){
				if(j==i*k){
					if(i==1)dp[i][j]=a[i]+a[j];
					else{
						dp[i][j]=dp[i-1][j-k]+s[j];
					}
				}
				else{
					if(i==1){
						dp[i][j]=max(dp[i][j-1],s[j]);
					}
					else{
						dp[i][j]=max(dp[i][j-1],dp[i-1][j-k]+s[j]);
					}
				}
			}
		}
		
		printf("%d\n",dp[3][n]);
	}
	return 0;
}

    原文作者:动态规划
    原文地址: https://blog.csdn.net/bekote/article/details/79508834
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞