poj1294拓扑排序

Sorting It All Out

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 24933Accepted: 8662

Description

An ascending sorted sequence of distinct values is one in which some form of a less-than operator is used to order the elements from smallest to largest. For example, the sorted sequence A, B, C, D implies that A < B, B < C and C < D. in this problem, we will give you a set of relations of the form A < B and ask you to determine whether a sorted order has been specified or not.

Input

Input consists of multiple problem instances. Each instance starts with a line containing two positive integers n and m. the first value indicated the number of objects to sort, where 2 <= n <= 26. The objects to be sorted will be the first n characters of the uppercase alphabet. The second value m indicates the number of relations of the form A < B which will be given in this problem instance. Next will be m lines, each containing one such relation consisting of three characters: an uppercase letter, the character “<” and a second uppercase letter. No letter will be outside the range of the first n letters of the alphabet. Values of n = m = 0 indicate end of input.

Output

For each problem instance, output consists of one line. This line should be one of the following three:

Sorted sequence determined after xxx relations: yyy…y.
Sorted sequence cannot be determined.
Inconsistency found after xxx relations.

where xxx is the number of relations processed at the time either a sorted sequence is determined or an inconsistency is found, whichever comes first, and yyy…y is the sorted, ascending sequence.

Sample Input

4 6
A<B
A<C
B<C
C<D
B<D
A<B
3 2
A<B
B<A
26 1
A<Z
0 0

Sample Output

Sorted sequence determined after 4 relations: ABCD.
Inconsistency found after 2 relations.
Sorted sequence cannot be determined.

先判断是否有环,再判断是否无法排序,第二步判断之后不能立即跳出,因为无法确定之后是否有环;

#include<cstdio>
#include<iostream>
#include<cstring>
using namespace std;
int mp[30][30],in[30],q[30];
int topo(int n)
{
    int c=0,temp[30],loc,m,flag=1;
    for(int i=1;i<=n;i++)
        temp[i]=in[i];
    for(int i=1;i<=n;i++)
    {
        m=0;
        for(int j=1;j<=n;j++)
            if(temp[j]==0)
        {
            m++;
            loc=j;//记录0入度点的位置
        }
        if(m==0)
            return 0;
        if(m>1)
            flag=-1;//说明此时无序,但不能判断之后是否有环
        q[c++]=loc;
        temp[loc]=-1;
        for(int j=1;j<=n;j++)
            if(mp[loc][j])
            temp[j]–;
    }
    return flag;
}
int main()
{
    int m,n,sign;
    char str[5];
    while(~scanf(“%d%d”,&n,&m)&&n&&m)
    {
        memset(mp,0,sizeof(mp));
        memset(in,0,sizeof(in));
        sign=0;
        for(int i=1;i<=m;i++)
        {
            scanf(“%s”,str);
            if(sign)
                continue;
            int x=str[0]-‘A’+1;
            int y=str[2]-‘A’+1;
            mp[x][y]=1;
            in[y]++;
            int s=topo(n);
            if(s==0)
            {
                printf(“Inconsistency found after %d relations.\n”,i);
                sign=1;
            }
            if(s==1)
            {
                printf(“Sorted sequence determined after %d relations: “,i);
                for(int j=0;j<n;j++)
                    printf(“%c”,q[j]+’A’-1);
                printf(“.\n”);
                sign=1;
            }
        }
        if(!sign)
            printf(“Sorted sequence cannot be determined. \n”);
    }
    return 0;
}

    原文作者:拓扑排序
    原文地址: https://blog.csdn.net/whiskey_wei/article/details/77056293
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞