HDU 3032 Nim or not Nim?(博弈,SG打表找规律)

Nim or not Nim?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 613    Accepted Submission(s): 282

Problem Description Nim is a two-player mathematic game of strategy in which players take turns removing objects from distinct heaps. On each turn, a player must remove at least one object, and may remove any number of objects provided they all come from the same heap.

Nim is usually played as a misere game, in which the player to take the last object loses. Nim can also be played as a normal play game, which means that the person who makes the last move (i.e., who takes the last object) wins. This is called normal play because most games follow this convention, even though Nim usually does not.

Alice and Bob is tired of playing Nim under the standard rule, so they make a difference by also allowing the player to separate one of the heaps into two smaller ones. That is, each turn the player may either remove any number of objects from a heap or separate a heap into two smaller ones, and the one who takes the last object wins.  

 

Input Input contains multiple test cases. The first line is an integer 1 ≤ T ≤ 100, the number of test cases. Each case begins with an integer N, indicating the number of the heaps, the next line contains N integers s[0], s[1], …., s[N-1], representing heaps with s[0], s[1], …, s[N-1] objects respectively.(1 ≤ N ≤ 10^6, 1 ≤ S[i] ≤ 2^31 – 1)  

 

Output For each test case, output a line which contains either “Alice” or “Bob”, which is the winner of this game. Alice will play first. You may asume they never make mistakes.  

 

Sample Input 2 3 2 2 3 2 3 3  

 

Sample Output Alice Bob  

 

Source
2009 Multi-University Training Contest 13 – Host by HIT  

 

Recommend gaojie  

 

通过SG函数打表可以发现规律。

当n=4*k时,sg[n] = n-1;

当n= 4*k+3 时,sg[n] = n+1;

其余sg[n] = n;

#include <stdio.h>
#include <algorithm>
#include <iostream>
#include <string.h>
using namespace std;
const int MAXN = 10000;
int SG(int x)
{
    if(x == 0)return x;
    if(x % 4 == 0)return x-1;
    if(x % 4 == 3)return x+1;
    return x;
}
int main()
{
    int T;
    int n,a;
    int sum;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        sum = 0;
        for(int i = 0;i < n;i++)
        {
            scanf("%d",&a);
            sum ^= SG(a);
        }
        if(sum == 0)printf("Bob\n");
        else printf("Alice\n");
    }
    return 0;
}

 

 

 

 

 

    原文作者:算法小白
    原文地址: https://www.cnblogs.com/kuangbin/p/3217845.html
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞