hdoj 5199 Gunner map

Gunner

Time Limit: 1 Sec  Memory Limit: 256 MB

题目连接

http://acm.hdu.edu.cn/showproblem.php?pid=5199

Description

Long long ago, there is a gunner whose name is Jack. He likes to go hunting very much. One day he go to the grove. There are n birds and n trees. The i−th bird stands on the top of the i−th tree. The trees stand in straight line from left to the right. Every tree has its height. Jack stands on the left side of the left most tree. When Jack shots a bullet in height H to the right, the bird which stands in the tree with height H will falls.
Jack will shot many times, he wants to know how many birds fall during each shot.

a bullet can hit many birds, as long as they stand on the top of the tree with height of H.

Input

There are multiple test cases (about 5), every case gives n,m in the first line, n indicates there are n trees and n birds, m means Jack will shot m times.

In the second line, there are n numbers h[1],h[2],h[3],…,h[n] which describes the height of the trees.

In the third line, there are m numbers q[1],q[2],q[3],…,q[m] which describes the height of the Jack’s shots.

Please process to the end of file.

[Technical Specification]

1≤n,m≤1000000(106)

1≤h[i],q[i]≤1000000000(109)

All inputs are integers.


Output

For each q[i], output an integer in a single line indicates the number of birds Jack shot down.

Sample Input

4 3 1 2 3 4 1 1 4


Sample Output

1 0 1

HINT

题意

 

   给你n个数m次询问,问你大小为A的数有多少个,第二次问的时候,就直接输出0就好

 

题解:

 

map可过,非常轻松(雾

~\(≧▽≦)/~啦啦啦

 

代码:

 

#include<cstdio>
#include<map>
using namespace std;
map<int,int> g;
int n,m;
inline int read()
{
    int x=0,f=1;char ch=getchar();
    while(ch<'0'||ch>'9'){if(ch=='-')f=-1;ch=getchar();}
    while(ch>='0'&&ch<='9'){x=x*10+ch-'0';ch=getchar();}
    return x*f;
}
int main()
{
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        g.clear();
        for(int i=0;i<n;i++)
        {
            int x=read();
            g[x]++;
        }
        for(int i=0;i<m;i++)
        {
            int x=read();
            if(g.find(x)==g.end())
            {
                printf("0\n");
            }
            else
            {
                printf("%d\n",g[x]);
                g[x]=0;
            }
        }
    }
}

 

 

,

Gunner

Time Limit: 1 Sec  Memory Limit: 256 MB

题目连接

http://acm.hdu.edu.cn/showproblem.php?pid=5199

Description

Long long ago, there is a gunner whose name is Jack. He likes to go hunting very much. One day he go to the grove. There are n birds and n trees. The i−th bird stands on the top of the i−th tree. The trees stand in straight line from left to the right. Every tree has its height. Jack stands on the left side of the left most tree. When Jack shots a bullet in height H to the right, the bird which stands in the tree with height H will falls.
Jack will shot many times, he wants to know how many birds fall during each shot.

a bullet can hit many birds, as long as they stand on the top of the tree with height of H.

Input

There are multiple test cases (about 5), every case gives n,m in the first line, n indicates there are n trees and n birds, m means Jack will shot m times.

In the second line, there are n numbers h[1],h[2],h[3],…,h[n] which describes the height of the trees.

In the third line, there are m numbers q[1],q[2],q[3],…,q[m] which describes the height of the Jack’s shots.

Please process to the end of file.

[Technical Specification]

1≤n,m≤1000000(106)

1≤h[i],q[i]≤1000000000(109)

All inputs are integers.


Output

For each q[i], output an integer in a single line indicates the number of birds Jack shot down.

Sample Input

4 3 1 2 3 4 1 1 4


Sample Output

1 0 1

HINT

题意

 

   给你n个数m次询问,问你大小为A的数有多少个,第二次问的时候,就直接输出0就好

 

题解:

 

map可过,非常轻松(雾

~\(≧▽≦)/~啦啦啦

 

代码:

 

#include<cstdio>
#include<map>
using namespace std;
map<int,int> g;
int n,m;
inline int read()
{
    int x=0,f=1;char ch=getchar();
    while(ch<'0'||ch>'9'){if(ch=='-')f=-1;ch=getchar();}
    while(ch>='0'&&ch<='9'){x=x*10+ch-'0';ch=getchar();}
    return x*f;
}
int main()
{
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        g.clear();
        for(int i=0;i<n;i++)
        {
            int x=read();
            g[x]++;
        }
        for(int i=0;i<m;i++)
        {
            int x=read();
            if(g.find(x)==g.end())
            {
                printf("0\n");
            }
            else
            {
                printf("%d\n",g[x]);
                g[x]=0;
            }
        }
    }
}

 

 

,

 

#include<cstdio>
#include<map>
using namespace std;
map<int,int> g;
int n,m;
inline int read()
{
    int x=0,f=1;char ch=getchar();
    while(ch<'0'||ch>'9'){if(ch=='-')f=-1;ch=getchar();}
    while(ch>='0'&&ch<='9'){x=x*10+ch-'0';ch=getchar();}
    return x*f;
}
int main()
{
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        g.clear();
        for(int i=0;i<n;i++)
        {
            int x=read();
            g[x]++;
        }
        for(int i=0;i<m;i++)
        {
            int x=read();
            if(g.find(x)==g.end())
            {
                printf("0\n");
            }
            else
            {
                printf("%d\n",g[x]);
                g[x]=0;
            }
        }
    }
}

 

 

    原文作者:qscqesze
    原文地址: https://www.cnblogs.com/qscqesze/p/4393227.html
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞