POJ-2251 迷宫问题

You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides. 

Is an escape possible? If yes, how long will it take? 

Input The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size). 

L is the number of levels making up the dungeon. 

R and C are the number of rows and columns making up the plan of each level. 

Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a ‘#’ and empty cells are represented by a ‘.’. Your starting position is indicated by ‘S’ and the exit by the letter ‘E’. There’s a single blank line after each level. Input is terminated by three zeroes for L, R and C. Output Each maze generates one line of output. If it is possible to reach the exit, print a line of the form 

Escaped in x minute(s).

where x is replaced by the shortest time it takes to escape. 

If it is not possible to escape, print the line 

Trapped!

Sample Input

3 4 5
S....
.###.
.##..
###.#

#####
#####
##.##
##...

#####
#####
#.###
####E

1 3 3
S##
#E#
###

0 0 0

Sample Output

Escaped in 11 minute(s).
Trapped!

#include<stdio.h>
#include<iostream>
#include<math.h>
#include<algorithm>
#include<string.h>
#include<vector>
#include<stack>
#include<set>
#include<queue>
using namespace std;
/*
利用广搜,用坐标来记录所在的位置,每次走都有上下左右前后六个方向可以走,把走过的标记一下,
如果队列为空还没走到终点就说明不能走到 
*/
const int maxx=35;
char map[maxx][maxx][maxx];
int x[6]= {1,-1},y[6]= {0,0,1,-1},z[6]= {0,0,0,0,1,-1};
int r,l,c;
struct ac {
	int x,y,z,step;
} start,end;

ac bfs(ac now) {
	queue<ac>q;
	ac next;
	q.push(now);
	while(!q.empty()) {
		now=q.front();
		q.pop();
		if(now.x==end.x&&now.y==end.y&&now.z==end.z)
			return now;
		for(int i=0; i<6; i++) {
			next.x=now.x+x[i];
			next.y=now.y+y[i];
			next.z=now.z+z[i];
			next.step=now.step+1;
			if(next.x>=0 && next.x<r && next.y>=0 && next.y<c && next.z>=0 && next.z<l&&map[next.z][next.x][next.y]!='#') {
				q.push(next);
				map[next.z][next.x][next.y]='#';

			}
		}
	}
	ac w;
	w.step=-1;
	return w;
}

int main() {

	while(cin>>l>>r>>c) {
		if(l==0&r==0&c==0) return 0;
		for(int i=0; i<l; i++) {
			for(int j=0; j<r; j++) {
				for(int jj=0; jj<c; jj++) {
					cin>>map[i][j][jj];
					if(map[i][j][jj]=='S') {
						start.x=j;
						start.z=i;
						start.y=jj;
					} else if(map[i][j][jj]=='E') {
						end.x=j;
						end.z=i;
						end.y=jj;
					}
				}

			}
			getchar();
		}
		start.step=0;
		ac ans=bfs(start);
		int s=ans.step;
		if(s==-1)
           cout<<"Trapped!\n";
        else cout<<"Escaped in "<<s<<" minute(s).\n";
	}
	return 0;
}

    原文作者:迷宫问题
    原文地址: https://blog.csdn.net/qq_41199327/article/details/79755910
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞