F - 迷宫问题

题记:虽然只有一组输出,但是按照正规输入的话,还是很难的         @.@

F –
迷宫问题
Time Limit:1000MS    Memory Limit:65536KB    64bit IO Format:%I64d & %I64u
Submit
Status

Description

定义一个二维数组:

int maze[5][5] = {

 0, 1, 0, 0, 0,

 0, 1, 0, 1, 0,

 0, 0, 0, 0, 0,

 0, 1, 1, 1, 0,

 0, 0, 0, 1, 0,

};

它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。

Input

一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。

Output

左上角到右下角的最短路径,格式如样例所示。

Sample Input

0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0

Sample Output

(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int map[5][5];
int vis[5][5];//全局数组
struct node{
    int x;
    int y;
    int pre;

}edge[100];//结构体
int front=0,rear=1;
int dir[4][2]={{0,-1},{1,0},{0,1},{-1,0}};//四个方向
void f(int i)
{
    if(edge[i].pre!=-1)
    {
        f(edge[i].pre);
        printf("(%d,%d)\n",edge[i].x,edge[i].y);

    }
}
void BFS(int x,int y)
{
    edge[front].x=x;
    edge[front].y=y;
    edge[front].pre=-1;//头节点
    while(front<rear)
    {
        int u;
        for(u=0;u<4;u++)
        {
            int x=edge[front].x+dir[u][0];
            int y=edge[front].y+dir[u][1];
            if(x<0||x>=5||y<0||y>=5||vis[x][y]==1||map[x][y]==1)
            continue;
            else
            {
                vis[x][y]=1;
                map[x][y]=1;
                edge[rear].x=x;
                edge[rear].y=y;
                edge[rear].pre=front;//前节点
                rear++;
            }
            if(x==4&&y==4)
            f(front);//从(0,0)——(4,4)的节点输出
        }
        front++;
    }
}
int main()//主函数
{
    int i,j;
    for(i=0;i<5;i++)
    {
        for(j=0;j<5;j++)
        scanf("%d",&map[i][j]);
    }
    memset(vis,0,sizeof(vis));
    printf("(0,0)\n");
    BFS(0,0);
    printf("(4,4)\n");
    return 0;
}
    原文作者:迷宫问题
    原文地址: https://blog.csdn.net/u013246297/article/details/43482709
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞