打印杨辉三角 要求按照规定格式打印前N行杨辉三角。

输入格式:

输入在一行中给出N(1≤N≤10)。

输出格式:

以正三角形的格式输出前N行杨辉三角。每个数字占固定4位。

输入样例:

6
输出样例:

    1
   1   1
  1   2   1
 1   3   3   1
1   4   6   4   1

1 5 10 10 5 1

#include<stdio.h>
int main()
{
  int a[11][11],i,j,n,p;
  scanf("%d",&n);
  a[0][0]=0;
  for(i=0;i<n;i++)
  {
    for(p=0;p<n-i-1;p++)
    {
      printf(" ");
    }
    for(j=0;j<=i;j++)
    {
      if(i==j)
      {
        a[i][j]=1;
      }
      else if(j==0)
      {
        a[i][j]=1;
      }
      else
      {
      a[i][j]=a[i-1][j-1]+a[i-1][j];
      }
      printf("%4d",a[i][j]);
      if(i==j)
      printf("\n");
    }
  }
  return 0;
}

    原文作者:杨辉三角问题
    原文地址: https://blog.csdn.net/qq_43634412/article/details/85713548
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞