杨辉三角 (sdut oj)

杨辉三角

Time Limit: 1000MS 
Memory Limit: 65536KB

Problem Description

1  1

1  2   1

1  3   3   1

1  4   6   4  1

1  5 10 10  5  1 

上面的图形熟悉吗?它就是我们中学时候学过的杨辉三角。

Input

输入数据包含多组测试数据。

每组测试数据的输入只有一个正整数n(1≤n≤30),表示将要输出的杨辉三角的层数。 

输入以0结束。

Output

对应于每一个输入,请输出相应层数的杨辉三角,每一层的整数之间用一个空格隔开,每一个杨辉三角后面加一个空行。

Example Input

2
3
0

Example Output

1
1 1

1
1 1
1 2 1

Hint

 

Author

ZJGSU

参考代码

#include<stdio.h>
int main()
{
    int a[30][30];
    int i,j;
    int n;
    while(~scanf("%d",&n) && n)
    {
        for(i = 0; i < n; i++)
        {
            for(j = 0; j <= i; j++)
            {
                if(j == 0 || j == i)
                    a[i][j] = 1;
                else
                    a[i][j] = a[i-1][j] + a[i-1][j-1];
            }
        }
        for(i = 0; i < n; i++)
        {
            for(j = 0; j <= i; j++)
            {
                if(j == i)
                    printf("%d\n",a[i][j]);
                else
                    printf("%d ",a[i][j]);
            }
        }
        printf("\n");
    }
    return 0;
}
    原文作者:杨辉三角问题
    原文地址: https://blog.csdn.net/SwordsMan98/article/details/54809993
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞