/*
一类括号匹配问题
查看 提交 统计 提问
总时间限制: 1000ms 内存限制: 65536kB
描述
在程序设计中,常常使用小括号强调表达式的运算顺序,但是,左右小括号必须匹配。现给定一个不多于500个符号的表达式(串),其中可能存在多个小括号,想检查小括号的匹配问题。如果存在小括号不匹配,则输出 mismatch;如果所有小括号匹配,则按左右括号的匹配距离由小到大输出左、右括号的位置;若多个匹配的距离相等,则左括号先出现的匹配先输出;如果整个串中没有小括号,则左右位置均输出0,即 0,0; ,规定,串中第一个符号的位置为1。
匹配距离=右括号位置 - 左括号位置。
例如:
输入为: (x+y*(z-5)*(x+y))*(x+98)
输出为:
6,10
12,16
19,24
1,17
如果输入为 (x+y*(z-5))*x+y)
则不匹配,因为在最后的反括号没有相匹配的正括号。因此,输出:
mismatch
输入
一串符号
输出
按匹配距离的增序输出匹配对的左右位置,逗号间隔;如果距离相同,则按左括号出现的先后顺序输出;如果整个序列中出现不匹配现象,则输出 mismatch;
样例输入
(x+y*(z-5)*(x+y))*(x+98)
样例输出
6,10
12,16
19,24
1,17
与之前一样,运用了栈的思想
不过此处因为需要将距离差按照一定顺序输出,故另设了一个set容器以储存位置
此处需注意的是要自定义比较器,用myComp类来实现
*/
#include<iostream>
#include<algorithm>
#include<stack>
#include<string>
#include<set>
using namespace std;
struct Point
{
int first,last;
};
struct myComp
{
bool operator () (const Point & a,const Point & b)
{
if((a.last-a.first) != (b.last-b.first))
return (a.last-a.first) < (b.last-b.first);
return a.first < b.first;
}
};
int main()
{
string a;
cin >> a;
stack<int> stk;
set<Point,myComp> delta;
set<Point>::iterator ite;
Point sample;
bool match = true;
int len = a.size();
for(int i = 0; i < len; ++i)
{
if(a[i] == '(')
stk.push(i);
if(a[i] == ')' && stk.empty())
{
cout << "mismatch" << endl;
match = false;
break;
}
if(a[i] == ')' && !stk.empty())
{
sample.first = stk.top();
sample.last = i;
delta.insert(sample);
stk.pop();
}
}
if(match)
{
for(ite = delta.begin(); ite != delta.end();++ite)
cout << ite->first+1 << ',' << ite->last+1 << endl;
}
system("pause");
return 0;
}
一类括号匹配问题
原文作者:括号匹配问题
原文地址: https://blog.csdn.net/u014391294/article/details/27369237
本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
原文地址: https://blog.csdn.net/u014391294/article/details/27369237
本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。