poj3239 n皇后问题快速得到一个解

Solution to the 
n Queens Puzzle

Time Limit: 1000MS Memory Limit: 131072K
Total Submissions: 3704 Accepted: 1356 Special Judge

Description

The eight queens puzzle is the problem of putting eight chess queens on an 8 × 8 chessboard such that none of them is able to capture any other. The puzzle has been generalized to arbitrary n × nboards. Given n, you are to find a solution to the n queens puzzle.

《poj3239 n皇后问题快速得到一个解》

Input

The input contains multiple test cases. Each test case consists of a single integer n between 8 and 300 (inclusive). A zero indicates the end of input.

Output

For each test case, output your solution on one line. The solution is a permutation of {1, 2, …, n}. The number in the ith place means the ith-column queen in placed in the row with that number.

Sample Input

8
0

Sample Output

5 3 1 6 8 2 4 7

Source

POJ Monthly–2007.06.03, Yao, Jinyu

这道题时间要求太高,而且只要求得到一个解,所以回溯法无论怎么剪枝都不可能达到要求(至少我不行),所以在网上找到一个求一个通解的方法。

下面用一个数列表示一种方案,第i个数表示棋盘第i行上的皇后所在的列号

n皇后问题构造法:

一、当n mod 6 != 2 且 n mod 6 != 3时,有一个解为:
2,4,6,8,…,n,1,3,5,7,…,n-1        (n为偶数)
2,4,6,8,…,n-1,1,3,5,7,…,n        (n为奇数)
(上面序列第i个数为ai,表示在第i行ai列放一个皇后;…省略的序列中,相邻两数以2递增。下同)
二、当n mod 6 == 2 或 n mod 6 == 3时,
(当n为偶数,k=n/2;当n为奇数,k=(n-1)/2) (实际上 都是 k = n/2, 因为会截尾)
k,k+2,k+4,…,n,2,4,…,k-2,k+3,k+5,…,n-1,1,3,5,…,k+1        (k为偶数,n为偶数)
k,k+2,k+4,…,n-1,2,4,…,k-2,k+3,k+5,…,n-2,1,3,5,…,k+1,n    (k为偶数,n为奇数)
k,k+2,k+4,…,n-1,1,3,5,…,k-2,k+3,…,n,2,4,…,k+1            (k为奇数,n为偶数)
k,k+2,k+4,…,n-2,1,3,5,…,k-2,k+3,…,n-1,2,4,…,k+1,n        (k为奇数,n为奇数)

第二种情况可以认为是,当n为奇数时用最后一个棋子占据最后一行的最后一个位置,然后用n-1个棋子去填充n-1的棋盘,这样就转化为了相同类型且n为偶数的问题。

若k为奇数,则数列的前半部分均为奇数,否则前半部分均为偶数。

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <cmath>

using namespace std;


void queens_puzzle(int n)//n>=8
{
    if(n%6!=2 && n%6!=3)
    {
        printf("2");
        for(int i=4;i<=n;i+=2)
            printf(" %d",i);
        for(int i=1;i<=n;i+=2)
            printf(" %d",i);
        printf("\n");
    }
    else
    {
        int k=n/2;
        if(n%2==0 && k%2==0)
        {
            printf("%d",k);
            for(int i=k+2;i<=n;i+=2)
                printf(" %d",i);
            for(int i=2;i<=k-2;i+=2)
                printf(" %d",i);
            for(int i=k+3;i<=n-1;i+=2)
                printf(" %d",i);
            for(int i=1;i<=k+1;i+=2)
                printf(" %d",i);
        }
        else if(n%2==1 && k%2==0)
        {
            printf("%d",k);
            for(int i=k+2;i<=n-1;i+=2)
                printf(" %d",i);
            for(int i=2;i<=k-2;i+=2)
                printf(" %d",i);
            for(int i=k+3;i<=n-2;i+=2)
                printf(" %d",i);
            for(int i=1;i<=k+1;i+=2)
                printf(" %d",i);
            printf(" %d",n);
        }
        else if(n%2==0 && k%2==1)
        {
            printf("%d",k);
            for(int i=k+2;i<=n-1;i+=2)
                printf(" %d",i);
            for(int i=1;i<=k-2;i+=2)
                printf(" %d",i);
            for(int i=k+3;i<=n;i+=2)
                printf(" %d",i);
            for(int i=2;i<=k+1;i+=2)
                printf(" %d",i);
        }
        else
        {
            printf("%d",k);
            for(int i=k+2;i<=n-2;i+=2)
                printf(" %d",i);
            for(int i=1;i<=k-2;i+=2)
                printf(" %d",i);
            for(int i=k+3;i<=n-1;i+=2)
                printf(" %d",i);
            for(int i=2;i<=k+1;i+=2)
                printf(" %d",i);
            printf(" %d",n);
        }
        printf("\n");
    }
}

int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        if(!n) break;
        queens_puzzle(n);
    }
    return 0;
}

    原文作者:八皇后问题
    原文地址: https://blog.csdn.net/Simon_coder/article/details/52387833
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞