HDU 1026 Ignatius and the Princess I (BFS)

Ignatius and the Princess I

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 16464    Accepted Submission(s): 5228
Special Judge


Problem Description
The Princess has been abducted by the BEelzebub feng5166, our hero Ignatius has to rescue our pretty Princess. Now he gets into feng5166’s castle. The castle is a large labyrinth. To make the problem simply, we assume the labyrinth is a N*M two-dimensional array which left-top corner is (0,0) and right-bottom corner is (N-1,M-1). Ignatius enters at (0,0), and the door to feng5166’s room is at (N-1,M-1), that is our target. There are some monsters in the castle, if Ignatius meet them, he has to kill them. Here is some rules:

1.Ignatius can only move in four directions(up, down, left, right), one step per second. A step is defined as follow: if current position is (x,y), after a step, Ignatius can only stand on (x-1,y), (x+1,y), (x,y-1) or (x,y+1).
2.The array is marked with some characters and numbers. We define them like this:
. : The place where Ignatius can walk on.
X : The place is a trap, Ignatius should not walk on it.
n : Here is a monster with n HP(1<=n<=9), if Ignatius walk on it, it takes him n seconds to kill the monster.

Your task is to give out the path which costs minimum seconds for Ignatius to reach target position. You may assume that the start position and the target position will never be a trap, and there will never be a monster at the start position.

 


Input
The input contains several test cases. Each test case starts with a line contains two numbers N and M(2<=N<=100,2<=M<=100) which indicate the size of the labyrinth. Then a N*M two-dimensional array follows, which describe the whole labyrinth. The input is terminated by the end of file. More details in the Sample Input.

 


Output
For each test case, you should output “God please help our poor hero.” if Ignatius can’t reach the target position, or you should output “It takes n seconds to reach the target position, let me show you the way.”(n is the minimum seconds), and tell our hero the whole path. Output a line contains “FINISH” after each test case. If there are more than one path, any one is OK in this problem. More details in the Sample Output.


Sample Input

5 6 .XX.1. ..X.2. 2…X. …XX. XXXXX. 5 6 .XX.1. ..X.2. 2…X. …XX. XXXXX1 5 6 .XX… ..XX1. 2…X. …XX. XXXXX.

Sample Output

It takes 13 seconds to reach the target position, let me show you the way. 1s:(0,0)->(1,0) 2s:(1,0)->(1,1) 3s:(1,1)->(2,1) 4s:(2,1)->(2,2) 5s:(2,2)->(2,3) 6s:(2,3)->(1,3) 7s:(1,3)->(1,4) 8s:FIGHT AT (1,4) 9s:FIGHT AT (1,4) 10s:(1,4)->(1,5) 11s:(1,5)->(2,5) 12s:(2,5)->(3,5) 13s:(3,5)->(4,5) FINISH It takes 14 seconds to reach the target position, let me show you the way. 1s:(0,0)->(1,0) 2s:(1,0)->(1,1) 3s:(1,1)->(2,1) 4s:(2,1)->(2,2) 5s:(2,2)->(2,3) 6s:(2,3)->(1,3) 7s:(1,3)->(1,4) 8s:FIGHT AT (1,4) 9s:FIGHT AT (1,4) 10s:(1,4)->(1,5) 11s:(1,5)->(2,5) 12s:(2,5)->(3,5) 13s:(3,5)->(4,5) 14s:FIGHT AT (4,5) FINISH God please help our poor hero. FINISH

Author
Ignatius.L


Recommend


题解:给你一个图,图上的标志如题所述,碰到怪兽就一定要把它杀死,求花时间最少的最短路径。
           BFS。。。。迄今写过的最长的BFS。。。醉了。。。(:渣渣。。


AC代码:

#include<iostream>       
#include<cstdlib>      
#include<cstdio> 
#include<cstring>      
#include<cmath>           
#include<string>      
#include<cstdlib>      
#include<iomanip>      
#include<vector>      
#include<list>      
#include<map>      
#include<queue>    
#include<algorithm>    
using namespace std;
char Map[105] [105];
int map2[105] [105]; //用来标志已经走过的路 
int dir[4][2]={{0,1},{1,0},{0,-1},{-1,0}};
int n,m;
struct node
{
	int s[1000][5];
	int steps;
	int x,y;
};
void bfs()
{
	queue<node>q;
	node s;
	s.steps = 0;
	s.x = 0;
	s.y = 0;
	q.push(s);
	while(!q.empty())
	{
		node s1 =q.front();
		q.pop();
		int x1 =s1.x;
		int y1= s1.y;
		//已经到达终点,并且怪兽都杀死了
		if(x1==m-1&&y1==n-1&&(Map[y1][x1]=='.'||Map[y1][x1]=='0'))
		{
			printf("It takes %d seconds to reach the target position, let me show you the way.\n", s1.steps);
			for(int i=0; i<s1.steps; i++) 
			{
				cout<<i+1<<"s:";
				int cnt = s1.s[i][0];
				if(cnt == 2)
				{
					printf("FIGHT AT (%d,%d)", s1.s[i][2], s1.s[i][1]);
				}
				else if(cnt == 4)
				{
					printf("(%d,%d)->(%d,%d)", s1.s[i][2], s1.s[i][1], s1.s[i][4], s1.s[i][3]);
				}
				cout<<endl;
			}
			return ;
		}
		//该点的怪兽还未杀死,不能往下一步跳
		else if(Map[y1][x1] != '.' && Map[y1][x1] != 'X' && Map[y1][x1] != '0')
		{
				node s2 ;
				s2.x = x1;
				s2.y = y1;
				for(int i=0; i<s1.steps; i++)
				{
					for(int j=0; j<5; j++)	
					{
						s2.s[i][j] = s1.s[i][j];
					}
				}
				//把作战的两个数字传入
				s2.s[s1.steps][0] = 2;
				s2.s[s1.steps][1] = x1;
				s2.s[s1.steps][2] = y1;
				s2.steps = s1.steps + 1;//步数加一
				Map[y1][x1] = Map[y1][x1] - 1;//地图上的点减小一,怪的血下降1滴
				q.push(s2);
		}
		else //可以往下一步跳	
			for(int i=0; i<4; i++)
			{
				int x2 = x1 + dir[i][0];
				int y2 = y1 + dir[i][1];
				if( x2>=0 && x2<m && y2 >=0 && y2 <n && map2[y2][x2] == 0)
				{
						if(Map[y2][x2] == 'X') continue;//如果是陷阱,就不去了
					else 
					{
						map2[y2][x2] = 1; //地图标记此点已经走过了
						node s2 ;
						s2.x = x2;
						s2.y = y2;
						for(int i1=0; i1<s1.steps; i1++)
						{
							for(int j1=0; j1< 5; j1++)	
						{
							s2.s[i1][j1] = s1.s[i1][j1];
						}
					}
					s2.s[s1.steps][0] = 4;
					s2.s[s1.steps][1] = x1;
					s2.s[s1.steps][2] = y1;
					s2.s[s1.steps][3] = x2;
					s2.s[s1.steps][4] = y2;
					s2.steps = s1.steps + 1; //步数加一
					q.push(s2);
				}
			}
		}
	}
	cout<<"God please help our poor hero."<<endl;
	return;
}
int main()
{
	while(cin>>n>>m)
	{
		char c;
		memset(map2,0,sizeof(map2)); 
		for(int i=0;i<n;i++)
		{
			for(int j=0;j<m;j++)
			{
			    cin>>c;
				Map[i][j]=c;	
			}
		}
		map2[0][0] =1;
		bfs();
		cout<<"FINISH"<<endl;
	}
	return 0;
}
    原文作者:BFS
    原文地址: https://blog.csdn.net/liangzhaoyang1/article/details/51525323
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞