Description
Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.
Input
The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.
Output
For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.
Sample Input
2
6
19
0
Sample Output
10
100100100100100100
111111111111111111
把所有只含1和0的数枚举出来取余就行,然后用G++交才能过。。。
#include <iostream>
#include <cstring>
#include <string>
#include <vector>
#include <queue>
#include <map>
#include <algorithm>
#define INF 0x3f3f3f3f
#define MAXN 1010
using namespace std;
void bfs(int n)
{
queue<long long> q;
q.push(1);
while(!q.empty())
{
long long tmp=q.front();
q.pop();
if(tmp%n==0)
{
cout<<tmp<<endl;
break;
}
q.push(tmp*10);
q.push(tmp*10+1);
}
}
int main()
{
ios::sync_with_stdio(false);
int n;
while(cin>>n&&n)
{
bfs(n);
}
return 0;
}