历届试题 分考场(dfs)

时间限制:1.0s 内存限制:256.0MB

问题描述
  n个人参加某项特殊考试。
  为了公平,要求任何两个认识的人不能分在同一个考场。
  求是少需要分几个考场才能满足条件。
输入格式
  第一行,一个整数n(1<n<100),表示参加考试的人数。
  第二行,一个整数m,表示接下来有m行数据
  以下m行每行的格式为:两个整数a,b,用空格分开 (1<=a,b<=n) 表示第a个人与第b个人认识。
输出格式
  一行一个整数,表示最少分几个考场。
样例输入
5
8
1 2
1 3
1 4
2 3
2 4
2 5
3 4
4 5
样例输出
4
样例输入
5
10
1 2
1 3
1 4
1 5
2 3
2 4
2 5
3 4
3 5
4 5
样例输出
5

题解:搜索一下,可以放到已经有的房间就放进去,考虑所有情况,每次搜索还要多开辟一个空间,本来想用二维vector 写,但是java里面好像没有二维vector,就用了两个数组去模拟了vector



import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
import java.util.Scanner;
import java.util.Vector;

public class Main {
	static int ans=110;
	static int [][]gre=new int [110][110];
	static int []cnt=new int [110];
	static int [][]ar=new int [110][110];
	static void dfs(int x,int now) {
		if(now >=ans) return;
		if(x==n+1) {
			ans=Math.min(now, ans);
			return ;
		}
		for(int i=1;i<=now;i++) {
			int w=cnt[i];
			int j=0;
			for(j=1;j<=w;j++) {
				if(gre[x][ar[i][j]]==1) {
					break;
				}
			}
			if(j==w+1) {
				cnt[i]++;
				ar[i][cnt[i]]=x;
				dfs(x+1,now);
				cnt[i]--;
			}
		}
		cnt[now+1]=1;
		ar[now+1][1]=x;
		dfs(x+1,now+1);
		cnt[now+1]=0;
	}
	static int n,k;
	public static void main(String[] args) throws IOException {
		Scanner sc=new Scanner(System.in);
		n=sc.nextInt();
		k=sc.nextInt();
	    
		for(int i=0;i<k;i++) {
			int a=sc.nextInt();
			int b=sc.nextInt();
			gre[a][b]=gre[b][a]=1;
		}
		dfs(1,0);
		System.out.println(ans);
	}

}

    原文作者:ffgcc
    原文地址: https://www.cnblogs.com/ffgcc/p/10546309.html
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞