题目描述
小z玩腻了迷宫游戏,于是他找到了Easy,准备和Easy玩这么一个游戏
小Z准备了一个字符串S (S的长度不超过10000)
又准备了M个小的字符串(M最大不超过1000000,每个小字符串的长度不超过10)
现在小z想请教Easy老师,M个小字符串中有多少个小字符串是大字符串S的子序列?
如果Easy老师答不上来就要请客,现在Easy老师很苦恼,你能帮帮他吗?
子序列可以理解为不要求连续的子串,若还是不了解请看下面的链接中,最佳答案的回答
https://zhidao.baidu.com/question/120638124.html
输入
只有一组测试数据
第一行是大字符串S(S的长度不超过10000)
第二行是一个整数M,表示小字符串的个数(M最大不超过1000000)
接下来M行每行给出一个小字符串(长度不超过10)
保证没有空字符串
输出
输出只有一个整数,代表M个小字符串中是大字符串S的子序列的个数
样例输入
amrocegijgyvkgarnffb
4
i
jsj
qg
ac
样例输出
2
#include<set>
#include<map>
#include<list>
#include<queue>
#include<stack>
#include<math.h>
#include<vector>
#include<bitset>
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#define eps (1e-8)
#define MAX 0x3f3f3f3f
#define u_max 1844674407370955161
#define l_max 9223372036854775807
#define i_max 2147483647
#define re register
#define pushup() tree[rt]=max(tree[rt<<1],tree[rt<<1|1])
#define nth(k,n) nth_element(a,a+k,a+n); // 将 第K大的放在k位
#define ko() for(int i=2;i<=n;i++) s=(s+k)%i // 约瑟夫
#define ok() v.erase(unique(v.begin(),v.end()),v.end()) // 排序,离散化
using namespace std;
inline int read(){
char c = getchar(); int x = 0, f = 1;
while(c < '0' || c > '9') {if(c == '-') f = -1; c = getchar();}
while(c >= '0' & c <= '9') x = x * 10 + c - '0', c = getchar();
return x * f;
}
typedef long long ll;
const double pi = atan(1.)*4.;
const int M=1e3+5;
const int N=1e5+5;
char s[N],s1[100];
vector<int>vv[27];
int a[27];
int main(){
scanf(" %s",s);
int len=strlen(s);
for(int i=0;i<len;i++)
vv[s[i]-'a'].push_back(i);
for(int i=0;i<27;i++)
vv[i].push_back(len);
int n,ans=0;
scanf("%d",&n);
while(n--){
memset(a,0,sizeof(a));
scanf(" %s",s1);
int leap=0;
int len1=strlen(s1);
int ss=vv[s1[0]-'a'][0];
if(ss==len)
continue ;
a[s1[0]-'a']=1;
for(int i=1;i<len1;i++){
int h=lower_bound(vv[s1[i]-'a'].begin()+a[s1[i]-'a'],
vv[s1[i]-'a'].end(),ss)-vv[s1[i]-'a'].begin();
a[s1[i]-'a']=h+1;
ss=vv[s1[i]-'a'][h];
if(ss==len){
leap=1;
break;
}
}
if(!leap)
ans++;
}
printf("%d\n",ans);
return 0;
}