There must be many A + B problems in our HDOJ , now a new one is coming.
Give you two hexadecimal integers , your task is to calculate the sum of them,and print it in hexadecimal too.
Easy ? AC it !
InputThe input contains several test cases, please process to the end of the file.
Each case consists of two hexadecimal integers A and B in a line seperated by a blank.
The length of A and B is less than 15.OutputFor each test case,print the sum of A and B in hexadecimal in one line.
Sample Input
+A -A +1A 12 1A -9 -1A -12 1A -AA
Sample Output
0 2C 11 -2C -90
这个题看起来比较简单。输入两个十六进制数然后相加,但有一个问题:结果大于0的时候直接输出就可以,但结果小于0的时候要做出处理:输出它的相反数即可,只要在输出前面加-号即可。代码如下:
#include <stdio.h>
#include <stdlib.h> int main()
{
long long int a,b,c;
while(~scanf(“%llX%llX”,&a,&b))
{
c=a+b;
if(c<0)
{
printf(“-%llX\n”,-c);
}
else printf(“%llX\n”,c);
}
return 0;
}