3.3小节——问题 B: Hello World for U

题目描述:

题目链接(含解析)
Given any string of N (>=5) characters, you are asked to form the characters into the shape of U. For example, “helloworld” can be printed as:

h  d

e  l

l  r

lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n1 characters, then left to right along the bottom line with n2 characters, and finally bottom-up along the vertical line with n3 characters. And more, we would like U to be as squared as possible – that is, it must be satisfied that n1 = n3 = max { k| k <= n2 for all 3 <= n2 <= N } with n1 + n2 + n3 – 2 = N.

输入

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

输出

For each test case, print the input string in the shape of U as specified in the description.

样例输入

helloworld!

样例输出

h   !
e   d
l   l
lowor

代码

#include<cstdio>
#include<cstring>
int main(){
    char str[85];
    int len=0,side,mid,i,j;
    while(scanf("%s",str)!=EOF){
        len=strlen(str);
        side=(len+2)/3;
        mid=len-side*2;
        for(i=0;i<side;i++){
            if(i!=side-1){
                printf("%c",str[i]);
                for(j=1;j<=mid;j++)printf(" ");
                printf("%c",str[len-1-i]);
            }else{
                for(j=side-1;j<=side+mid;j++)
                printf("%c",str[j]);
            }   
            printf("\n");
        }
    }
    return 0;
}
    原文作者:codeup题目解答
    原文地址: https://blog.csdn.net/weixin_42114379/article/details/82220239
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞