Bitset(十进制转二进制)

Link:http://acm.hdu.edu.cn/showproblem.php?pid=2051

Bitset

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 14434    Accepted Submission(s): 10985

Problem Description Give you a number on base ten,you should output it on base two.(0 < n < 1000)  

Input For each case there is a postive number n on base ten, end of file.  

Output For each case output a number on base two.  

Sample Input

1 2 3  

Sample Output

1 10 11  

Author 8600 && xhd  

Source
校庆杯Warm Up  

Recommend linle   |   We have carefully selected several similar problems for you:  
2055 
2052 
2053 
2054 
2071   

AC code:

#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdio>
#include<queue>
#include<cmath>
using namespace std;
int main()
{
	int n,a[111],cnt,i;
	while(scanf("%d",&n)!=EOF)
	{
		cnt=0;
		while(n)
		{
			a[cnt++]=n%2;
			n/=2;
		}
		for(i=cnt-1;i>=0;i--)
		{
			printf("%d",a[i]);
		}
		printf("\n");
	}
 } 

    原文作者:进制转换
    原文地址: https://blog.csdn.net/enjoying_science/article/details/43909661
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞