hdu4278 Faulty Odometer 八进制转十进制

Faulty Odometer

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1875    Accepted Submission(s): 1295

Problem Description   You are given a car odometer which displays the miles traveled as an integer. The odometer has a defect, however: it proceeds from the digit 2 to the digit 4 and from the digit 7 to the digit 9, always skipping over the digit 3 and 8. This defect shows up in all positions (the one’s, the ten’s, the hundred’s, etc.). For example, if the odometer displays 15229 and the car travels one mile, odometer reading changes to 15240 (instead of 15230).

 

Input   Each line of input contains a positive integer in the range 1..999999999 which represents an odometer reading. (Leading zeros will not appear in the input.) The end of input is indicated by a line containing a single 0. You may assume that no odometer reading will contain the digit 3 and 8.

 

Output   Each line of input will produce exactly one line of output, which will contain: the odometer reading from the input, a colon, one blank space, and the actual number of miles traveled by the car. 

 

Sample Input

15 2005 250 1500 999999 0  

Sample Output

15: 12 2005: 1028 250: 160 1500: 768 999999: 262143

#include <cstdio>
#include <cstring>
#include <iostream>

using namespace std;

int ans[50], cnt;

void cc(int n) {
	cnt = 0;
	do {
		ans[cnt++] = n % 10;
		n /= 10;
	} while (n);
	for (int i = 0; i < cnt; i++) {
		if (ans[i] > 3 && ans[i] < 8) {
			ans[i] -= 1;
		}
		else if (ans[i] == 9) {
			ans[i] -= 2;
		}
	}
}

int main()
{
	int n;
	while (~scanf("%d", &n) && n) {
		cc(n);
		int sum = 0;
		for (int i = cnt - 1; i >= 0; i--) {
			sum *= 8;
			sum += ans[i];
		}
		printf("%d: %d\n", n, sum);
	}
	return 0;
}
    原文作者:进制转换
    原文地址: https://blog.csdn.net/EventQueue/article/details/51194314
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞