hdu2594 next数组应用 -。-水过!

题目连接:http://acm.hdu.edu.cn/showproblem.php?pid=2594

Simpsons’ Hidden Talents

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 15958    Accepted Submission(s): 5442

 

Problem Description

Homer: Marge, I just figured out a way to discover some of the talents we weren’t aware we had.
Marge: Yeah, what is it?
Homer: Take me for example. I want to find out if I have a talent in politics, OK?
Marge: OK.
Homer: So I take some politician’s name, say Clinton, and try to find the length of the longest prefix
in Clinton’s name that is a suffix in my name. That’s how close I am to being a politician like Clinton
Marge: Why on earth choose the longest prefix that is a suffix???
Homer: Well, our talents are deeply hidden within ourselves, Marge.
Marge: So how close are you?
Homer: 0!
Marge: I’m not surprised.
Homer: But you know, you must have some real math talent hidden deep in you.
Marge: How come?
Homer: Riemann and Marjorie gives 3!!!
Marge: Who the heck is Riemann?
Homer: Never mind.
Write a program that, when given strings s1 and s2, finds the longest prefix of s1 that is a suffix of s2.

 

 

Input

Input consists of two lines. The first line contains s1 and the second line contains s2. You may assume all letters are in lowercase.

 

 

Output

Output consists of a single line that contains the longest string that is a prefix of s1 and a suffix of s2, followed by the length of that prefix. If the longest such string is the empty string, then the output should be 0.
The lengths of s1 and s2 will be at most 50000.

 

 

Sample Input

 

clinton homer riemann marjorie

 

 

Sample Output

 

0 rie 3

 

import java.util.Scanner;

public class Main {
	@SuppressWarnings("resource")
	public static void main(String[] args) {
		Scanner scanner = new Scanner(System.in);
		while (scanner.hasNext()) {
			String string = scanner.next();
			String desk = scanner.next();
			String string2 =string + desk;
			int next[] = getnext(string2);
			if (next[next.length - 1] == 0) {//next数组最后一位就是最大匹配,但需要注意字符串长度与next[next.length - 1]的关系。
				System.out.println(0);
			} else {
				int x = 0;
				if (next[next.length - 1] >= (x = Math.max(string.length(), desk.length()))) {
					if(x == string.length()) {
						System.out.println(desk + " " + desk.length());
					} else {
						System.out.println(string + " " + string.length());
					}
				} else {
					for (int i = 0; i < next[next.length - 1]; i++) {
	                    System.out.print(string.charAt(i));
	                }
	                System.out.print(" " + next[next.length - 1]);
	                System.out.println();
				}
			}
		}
	}
	public static int[] getnext(String desk){
        int next[] = new int[desk.length() + 1];
        int j = 0, k = -1;
        next[0] = -1;
        while(j < desk.length()){
            if(k == -1 || desk.charAt(j) == desk.charAt(k)){
                j ++;
                k ++;
                next[j] = k;
            }
            else
                k = next[k];
        }
        return next;
    }
}

 

点赞