Problem Description
哈利波特在魔法学校的必修课之一就是学习魔咒。据说魔法世界有100000种不同的魔咒,哈利很难全部记住,但是为了对抗强敌,他必须在危急时刻能够调用任何一个需要的魔咒,所以他需要你的帮助。
给你一部魔咒词典。当哈利听到一个魔咒时,你的程序必须告诉他那个魔咒的功能;当哈利需要某个功能但不知道该用什么魔咒时,你的程序要替他找到相应的魔咒。如果他要的魔咒不在词典中,就输出“what?”
Input
首先列出词典中不超过100000条不同的魔咒词条,每条格式为:
[魔咒] 对应功能
其中“魔咒”和“对应功能”分别为长度不超过20和80的字符串,字符串中保证不包含字符“[”和“]”,且“]”和后面的字符串之间有且仅有一个空格。词典最后一行以“@[email protected]”结束,这一行不属于词典中的词条。
词典之后的一行包含正整数N(<=1000),随后是N个测试用例。每个测试用例占一行,或者给出“[魔咒]”,或者给出“对应功能”。
Output
每个测试用例的输出占一行,输出魔咒对应的功能,或者功能对应的魔咒。如果魔咒不在词典中,就输出“what?”
Sample Input
[expelliarmus] the disarming charm
[rictusempra] send a jet of silver light to hit the enemy
[tarantallegra] control the movement of one’s legs
[serpensortia] shoot a snake out of the end of one’s wand
[lumos] light the wand
[obliviate] the memory charm
[expecto patronum] send a Patronus to the dementors
[accio] the summoning charm
4
[lumos]
the summoning charm
[arha]
take me to the sky
Sample Output
light the wand
accio
what?
what?
题目描述:
给你一个字典,让你实现查询的功能。
其实难点并不在于题意,主要是在于处理输入输出;输入输出我用的都是 gets() ,它能吃空格,也能吃行首的回车,所以用这个吃进去,然后进行分离,然后再进行处理。
切记:存字符串的数组,一定要开够大!我就是因为这个,错了无数次….
代码篇:
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
struct str{ //arr是单词 brr是功能 crr是整体
char arr[25],brr[85],crr[110]; //emmmm测试数据确实有满串,所以这个数组不能小
int x;
} str[100005];
int main()
{
char s[85];
int n,m=1,i;
while(gets(str[m].crr)){ //gest()输入整行,然后进行分离
if(str[m].crr[0] == '@') //如果是@[email protected],跳出
break;
for( i=0; i<strlen(str[m].crr); i++){
if(str[m].crr[i] == ']')
break;
str[m].arr[i] = str[m].crr[i];
}
str[m].arr[i]=']';
i += 2; //跳过中间的']' 和空格
for(int a=i; a<strlen(str[m].crr); a++){
str[m].brr[a-i] = str[m].crr[a];
}
m++;
}
scanf("%d ",&n);
while(n--){
gets(s);
int flag=0;
if(s[0]=='['){ //分开求,因为可能有一种情况,单词和功能一样,可能会混淆
for( i=1; i<m; i++){
if( strcmp( s , str[i].arr ) == 0){
printf("%s",str[i].brr);
flag = 1;
break;
}
}
}
else{
for( i=1; i<m; i++){
if( strcmp( s , str[i].brr ) == 0){
for(int j=1; j<strlen(str[i].arr)-1; j++) //不输出'['和']'
printf("%c",str[i].arr[j]);
flag = 1;
break;
}
}
}
if( !flag ){
printf("what?\n");
}
else
printf("\n");
}
return 0;
}