AVL树(模板题)—— POJ 3481 Double Queue

对应POJ题目:点击打开链接

Double Queue

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 11741 Accepted: 5335

Description

The new founded Balkan Investment Group Bank (BIG-Bank) opened a new office in Bucharest, equipped with a modern computing environment provided by IBM Romania, and using modern information technologies. As usual, each client of the bank is identified by a positive integer K and, upon arriving to the bank for some services, he or she receives a positive integer priority P. One of the inventions of the young managers of the bank shocked the software engineer of the serving system. They proposed to break the tradition by sometimes calling the serving desk with the lowest priority instead of that with the highest priority. Thus, the system will receive the following types of request:

0The system needs to stop serving
K PAdd client K to the waiting list with priority P
2Serve the client with the highest priority and drop him or her from the waiting list
3Serve the client with the lowest priority and drop him or her from the waiting list

Your task is to help the software engineer of the bank by writing a program to implement the requested serving policy.

Input

Each line of the input contains one of the possible requests; only the last line contains the stop-request (code 0). You may assume that when there is a request to include a new client in the list (code 1), there is no other request in the list of the same client or with the same priority. An identifier K is always less than 106, and a priority P is less than 107. The client may arrive for being served multiple times, and each time may obtain a different priority.

Output

For each request with code 2 or 3, the program has to print, in a separate line of the standard output, the identifier of the served client. If the request arrives when the waiting list is empty, then the program prints zero (0) to the output.

Sample Input

2
1 20 14
1 30 3
2
1 10 99
3
2
2
0

Sample Output

0
20
30
10
0

题意:

有3个操作:(1  x   y)表示以y为优先级在队列里插入一对数(x   y),其中每一对数的x和y均不同;(2)表示输出优先级最高的一对数中的x,(3)表示输出优先级最低的一对数中的x;(0)表示退出。


思路:

各种二叉排序树,还有STL里的map,set也可AC,贴AVL模板


#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#define MAX(x, y) ((x)>(y)?(x):(y))

typedef struct NODE
{
	int val, data;
	int bf; //平衡因子(左子树高度与右子树高度之差)
	int h; //以当前结点为根结点的数的高度
	NODE *l, *r;
}Node;

class BalanceTree
{
public:
	void Init()
	{
		rt = NULL;
	}
	int Height(Node *T)
	{
		if(NULL == T) return 0;
		return T->h;
	}
	int BF(Node *l, Node *r)
	{
		if(NULL == l && NULL == r) return 0;
		else if(NULL == l) return -r->h;
		else if(NULL == r) return l->h;
		else return l->h - r->h;
	}
	Node *LL_rotate(Node *A)
	{
		Node *B;
		B = A->l;
		A->l = B->r;
		B->r = A;
		A->h = MAX(Height(A->l), Height(A->r)) + 1;
		B->h = MAX(Height(B->l), Height(B->r)) + 1;
		A->bf = BF(A->l, A->r);
		B->bf = BF(B->l, B->r);
		return B;
	}
	Node *RR_rotate(Node *A)
	{
		Node *B;
		B = A->r;
		A->r = B->l;
		B->l = A;
		A->h = MAX(Height(A->l), Height(A->r)) + 1;
		B->h = MAX(Height(B->l), Height(B->r)) + 1;
		A->bf = BF(A->l, A->r);
		B->bf = BF(B->l, B->r);
		return B;
	}
	Node *LR_rotate(Node *A)
	{
		Node *C;
		A->l = RR_rotate(A->l);
		C = LL_rotate(A);
		return C;
	}
	Node *RL_rotate(Node *A)
	{
		Node *C;
		A->r = LL_rotate(A->r);
		C = RR_rotate(A);
		return C;
	}
	void Insert(int v, int e)
	{
		Insert_(rt, v, e);
	}
	void Insert_(Node *&T, int v, int e)
	{
		if(NULL == T){
			T = (Node *)malloc(sizeof(Node));
			T->val = v;
			T->data = e;
			T->bf = 0;
			T->h = 1;
			T->l = T->r = NULL;
			return;
		}
		if(e < T->data) Insert_(T->l, v, e);
		else Insert_(T->r, v, e);

		T->h = MAX(Height(T->l), Height(T->r)) + 1;
		T->bf = BF(T->l, T->r);

		if(T->bf > 1 || T->bf < -1){ //T结点失衡
			if(T->bf > 0 && T->l->bf > 0) T = LL_rotate(T); //如果T->bf > 0 则肯定有左儿子
			else if(T->bf < 0 && T->r->bf < 0) T = RR_rotate(T); //如果T->bf < 0 则肯定有右儿子
			else if(T->bf > 0 && T->l->bf < 0) T = LR_rotate(T);
			else if(T->bf < 0 && T->r->bf > 0) T = RL_rotate(T);
		}
	}
	void Delete(int flag) //flag为1表示找最大值
	{
		if(NULL == rt){
			printf("0\n");
			return;
		}
		Node *tmp = rt;
		if(!flag) while(tmp->l) tmp = tmp->l;
		else while(tmp->r) tmp = tmp->r;
		printf("%d\n", tmp->val);
		Delete_(rt, tmp->data);
	}
	void Delete_(Node *&T, int key)
	{
		if(NULL == T) return;
		if(key < T->data){ //从左边删除
			Delete_(T->l, key);
			T->bf = BF(T->l, T->r); //计算删除后T结点的平衡因子
			if(T->bf < -1){ //T结点左边高度变小(删了左边的元素)导致失衡
				if(1 == T->r->bf) T = RL_rotate(T); //RL型
				else T = RR_rotate(T); //平衡因子为0或-1
			}
		}
		else if(key > T->data){ //从右边删除
			Delete_(T->r, key);
			T->bf = BF(T->l, T->r); //计算删除后T结点的平衡因子
			if(T->bf > 1){ //T结点右边高度变小(删了右边的元素)导致失衡
				if(-1 == T->l->bf) T = LR_rotate(T); //LR型
				else T = LL_rotate(T); //平衡因子为0或1
			}
		}
		else{
			if(T->l && T->r){ //左右都不为空
				Node *tmp = T->l; //用被删除节点的左子树的最大值代替被删除节点
				while(tmp->r) tmp = tmp->r;

				T->data = tmp->data;
				T->val = tmp->val;

				Delete_(T->l, tmp->data);
				T->bf = BF(T->l, T->r); //计算删除后T结点的平衡因子
				if(T->bf < -1){ //T结点左边高度变小(删了左边的元素)导致失衡
					if(1 == T->r->bf) T = RL_rotate(T); //RL型
					else T = RR_rotate(T); //平衡因子为0或-1
				}
			}
			else{
				Node *tmp = T;
				if(T->l) T = T->l; //有左儿子
				else if(T->r) T = T->r; //有右儿子
				else{ //T无儿子
					free(T);
					T = NULL;
				}
				if(T) free(tmp);
			}
		}
	}
	void Show()
	{
		InOrder(rt);
		printf("\n");
	}
	void InOrder(Node *T)
	{
		if(NULL == T) return;
		InOrder(T->l);
		printf("%d(%d) ", T->val, T->data);
		InOrder(T->r);
	}
	void Free()
	{
		FreeTree(rt);
	}
	void FreeTree(Node *T)
	{
		if(NULL == T) return;
		FreeTree(T->l);
		FreeTree(T->r);
		free(T);
	}
private:
	Node *rt;
};

BalanceTree bt;

int main()
{
#if 0
	freopen("in.txt","r",stdin);
#endif
	int op, v, e;
	bt.Init();
	while(scanf("%d", &op), op)
	{
		if(1 == op){
			scanf("%d%d", &v, &e);
			bt.Insert(v, e);
		}
		else if(2 == op)
			bt.Delete(1);
		else if(3 == op)
			bt.Delete(0);
	}
	bt.Free();
	return 0;
}

    原文作者:AVL树
    原文地址: https://blog.csdn.net/u013351484/article/details/47189085
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞