ZOJ 3747 Attack on Titans

关键字:动态规划,带限制条件的计数递推

题目:
Over centuries ago, mankind faced a new enemy, the Titans. The difference of power between mankind and their newfound enemy was overwhelming. Soon, mankind was driven to the brink of extinction. Luckily, the surviving humans managed to build three walls: Wall Maria, Wall Rose and Wall Sina. Owing to the protection of the walls, they lived in peace for more than one hundred years.

But not for long, a colossal Titan appeared out of nowhere. Instantly, the walls were shattered, along with the illusory peace of everyday life. Wall Maria was abandoned and human activity was pushed back to Wall Rose. Then mankind began to realize, hiding behind the walls equaled to death and they should manage an attack on the Titans.

So, Captain Levi, the strongest ever human being, was ordered to set up a special operation squad of N people, numbered from 1 to N. Each number should be assigned to a soldier. There are three corps that the soldiers come from: the Garrison, the Recon Corp and the Military Police. While members of the Garrison are stationed at the walls and defend the cities, the Recon Corps put their lives on the line and fight the Titans in their own territory. And Military Police serve the King by controlling the crowds and protecting order. In order to make the team more powerful, Levi will take advantage of the differences between the corps and some conditions must be met.

The Garrisons are good at team work, so Levi wants there to be at least M Garrison members assigned with continuous numbers. On the other hand, members of the Recon Corp are all elite forces of mankind. There should be no more than K Recon Corp members assigned with continuous numbers, which is redundant. Assume there is unlimited amount of members in each corp, Levi wants to know how many ways there are to arrange the special operation squad.

Input
There are multiple test cases. For each case, there is a line containing 3 integers N (0 < N < 1000000), M (0 < M < 10000) and K (0 < K < 10000), separated by spaces.

Output
One line for each case, you should output the number of ways mod 1000000007.

Sample Input
3 2 2
Sample Output
5
Hint
Denote the Garrison, the Recon Corp and the Military Police as G, R and P. Reasonable arrangements are: GGG, GGR, GGP, RGG, PGG.

思路:
1.将至少的情况转换为至多的情况
事件A={至多n个G&&至多k个R}
事件B={至多m-1个G&&至多kgeR}
事件A-B={至少有m个G}

2.设dp[i][0] dp[i][1] dp[i][2]分别表示第i个位置(从1开始)为G、R、P时至多有u个连续G,至多有v个连续R的个数
设sum = dp[i-1][0]+dp[i-1][1]+dp[i-2][2]
当第I个为P时,无限制条件,dp[i][2] = sum
当第I个为G时,
i <= u时,dp[i] = sum
i == u+1时,dp[i] = sum – 1(此时减去从1至u全为G的情况(只有1种..))
i > u+1 时,dp[i] = sum – dp[i-u-1][1] – dp[i-u-1][2](此时减去从i-u至i-1全为G的情况(有dp[i-u-1][1] + dp[i-u-1][2]种))
当第I个为R时,同理。

链接:
http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=5170

代码:

#include <iostream>
#include <fstream>
#include <cstdio>
using namespace std;
#define ll long long
const int maxn = 1000010;
const int M = 1000000007;
ll dp[maxn][3];
int n;

ll f(int u, int v){
    ll sum = 0;
    dp[0][0] = 1;
    dp[0][1] = dp[0][2] = 0;

    for(int i = 1; i <= n; ++i){
        sum = (dp[i - 1][0] + dp[i - 1][1] + dp[i - 1][2]) % M;

        dp[i][2] = sum;

        if(i <= u) dp[i][0] = sum;
        else if(i == u + 1) dp[i][0] = (sum - 1)%M;
        else dp[i][0] = (sum - dp[i - u - 1][1] - dp[i - u - 1][2])%M;

        if(i <= v) dp[i][1] = sum;
        else if(i == v + 1) dp[i][1] = (sum - 1)%M;
        else dp[i][1] = (sum - dp[i - v - 1][0] - dp[i - v - 1][2])%M;
    }
    return (dp[n][0] + dp[n][1] + dp[n][2]) % M;
}

int main(){
// freopen("a.txt", "r", stdin);
    int m, k;
    while(scanf("%d %d %d", &n, &m, &k) != EOF){
        printf("%lld\n", (((f(n, k) - f(m - 1, k)) % M) + M) % M); //取正值..
    }
}
点赞