POJ_Biorhythms_递归_中国剩余定理求解

Biorhythms

Time Limit: 1000MS Memory Limit: 10000K

Description

Some people believe that there are three cycles in a person’s life that start the day he or she is born. These three cycles are the physical, emotional, and intellectual cycles, and they have periods of lengths 23, 28, and 33 days, respectively. There is one peak in each period of a cycle. At the peak of a cycle, a person performs at his or her best in the corresponding field (physical, emotional or mental). For example, if it is the mental curve, thought processes will be sharper and concentration will be easier.
Since the three cycles have different periods, the peaks of the three cycles generally occur at different times. We would like to determine when a triple peak occurs (the peaks of all three cycles occur in the same day) for any person. For each cycle, you will be given the number of days from the beginning of the current year at which one of its peaks (not necessarily the first) occurs. You will also be given a date expressed as the number of days from the beginning of the current year. You task is to determine the number of days from the given date to the next triple peak. The given date is not counted. For example, if the given date is 10 and the next triple peak occurs on day 12, the answer is 2, not 3. If a triple peak occurs on the given date, you should give the number of days to the next occurrence of a triple peak.

Input

You will be given a number of cases. The input for each case consists of one line of four integers p, e, i, and d. The values p, e, and i are the number of days from the beginning of the current year at which the physical, emotional, and intellectual cycles peak, respectively. The value d is the given date and may be smaller than any of p, e, or i. All values are non-negative and at most 365, and you may assume that a triple peak will occur within 21252 days of the given date. The end of input is indicated by a line in which p = e = i = d = -1.

Output

For each test case, print the case number followed by a message indicating the number of days to the next triple peak, in the form:

Case 1: the next triple peak occurs in 1234 days.

Use the plural form “days” even if the answer is 1.

Sample Input
0 0 0 0
0 0 0 100
5 20 34 325
4 5 6 7
283 102 23 320
203 301 203 40
-1 -1 -1 -1
Sample Output
Case 1: the next triple peak occurs in 21252 days.
Case 2: the next triple peak occurs in 21152 days.
Case 3: the next triple peak occurs in 19575 days.
Case 4: the next triple peak occurs in 16994 days.
Case 5: the next triple peak occurs in 8910 days.
Case 6: the next triple peak occurs in 10789 days.

/*
利用中国剩余定理CRT求三峯值日期date
CRT中需要利用    扩展欧几里得算法    求逆元
    date mod 23 = p;
    date mod 28 = e;
    date mod 33 = i;
    ==>
    date = p mod 23;
    date = e mod 28;
    date = i mod 33;
    其中23,28,33 两两互质
*/

#include "stdio.h"
#include "math.h"

/*
    q = gcd(a,b)=gcd(b,a%b) (b!=0)|| a (b==0)
        q   = a * x + b * y     
 */
int x,y,q,m=23*28*33;

void extend_Eulid(int a, int b){
    if(b == 0){
        x = 1;
        y = 0;
        q = a;//最大公约数
    }else{
        //利用递归性质,倒代求逆元
        extend_Eulid(b,a%b);
        /* gcd(a,b) = gcd(b,a%b) => q = a * x + b * y => r=a%b q = b * x1 + r * y1 a = b * k + r b = r * k' +r' ... gcd = b*x1 + (a-(a/b)*b)*y1
            = b*x1 + a*y1 – (a/b)*b*y1
            = a*y1 + b*(x1 – a/b*y1)

            x = y1
            y = x1 – a/b*y1
        */

        int tmp = x;
        x = y;
        y = tmp - a/b*y;
    }
}

int CRT(int *a,int *m,int Len){
    int i,j;
    int M[3],_M[3];
    int result = 0;
    for(i=0;i<Len;i++){
        M[i] = 1;
        for(j=0;j<Len;j++){
            if(j != i){
                //除去mi的所有m的累乘
                M[i]*=m[j];
            }
        }
        //printf("M%d: %d\n",i,M[i]);
        /* 因为所有mi互质,所以q = gcd(M[i],m[i]) = 1 q = M[i] * x + m[i] * y =1 M[i] * x = 1 mod m[i] 所以,Mi模mi的逆元_Mi就是 x */
        extend_Eulid(M[i],m[i]);
        if(x < 0){
            x += m[i];
        }
        _M[i] = x;
        //printf("M%d的逆元%d\n",i,x);
    }
    for(i=0;i<Len;i++){
        result+=a[i]*M[i]*_M[i];//CRT
    }
    return result%m;
}

void main(){
    int Len = 3,count=0;
    int m[3] ={23,28,33};
    int a[3],d;
    scanf("%d%d%d%d",&a[0],&a[1],&a[2],&d);
    while(a[0]!=-1&&a[1]!=-1&&a[2]!=-1&&d!=-1){
        //printf("%d %d %d %d \n",a[0],a[1],a[2],d);
        int result = CRT(a,m,Len) -d;
        if(result <= 0){
            result = 21252 + result;
        }
        printf("Case %d: the next triple peak occurs in %d days.\n",++count,result);
        scanf("%d%d%d%d",&a[0],&a[1],&a[2],&d);
    }
}
点赞