最短路
Problem Description
在每年的校赛里,所有进入决赛的同学都会获得一件很漂亮的t-shirt。但是每当我们的工作人员把上百件的衣服从商店运回到赛场的时候,却是非常累的!所以现在他们想要寻找最短的从商店到赛场的路线,你可以帮助他们吗?
Input
输入包括多组数据。每组数据第一行是两个整数N、M(N<=100,M<=10000),N表示成都的大街上有几个路口,标号为1的路口是商店所在地,标号为N的路口是赛场所在地,M则表示在成都有几条路。N=M=0表示输入结束。接下来M行,每行包括3个整数A,B,C(1<=A,B<=N,1<=C<=1000),表示在路口A与路口B之间有一条路,我们的工作人员需要C分钟的时间走过这条路。
输入保证至少存在1条商店到赛场的路线。
Output
对于每组输入,输出一行,表示工作人员从商店走到赛场的最短时间
Sample Input
2 1
1 2 3
3 3
1 2 5
2 3 5
3 1 2
0 0
Sample Output
3
2
代码
#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn = 105;
const int maxm = 10005;
const int INF = 0x3f3f3f3f;
int Map[maxn][maxn];//邻接矩阵
bool book[maxn];//标记dis数组
int dis[maxn];
int dijstra(int n, int s, int e)//s为开始点e为结束点
{
memset(book,0,sizeof(book));
for(int i = 0; i < n; i++)
{
dis[i] = Map[s][i];
}
book[s] = true;
dis[s] = 0;
for(int i = 0; i < n; i++)
{
int pos;
int minv = INF;
for(int j = 0; j < n; j++)//找到当前dis数组中还可以松弛的最小点
{
if(!book[j] && minv > dis[j])
{
pos = j;
minv = dis[j];
}
}
book[pos] = true;
for(int j = 0; j < n; j++)//以刚刚找到的点,松弛剩下的点
{
if(!book[j] && dis[j] > dis[pos] + Map[pos][j])
{
dis[j] = dis[pos] + Map[pos][j];
}
}
}
return dis[e];
}
int main()
{
int n,m;
while(cin>>n>>m && (n+m))
{
for(int i = 0; i < n; i++)
{
for(int j = 0; j < n; j++)
{
Map[i][j] = INF;
}
}
int a,b,c;
for(int i = 0; i < m; i++)
{
cin>>a>>b>>c;
Map[a-1][b-1] = c;
Map[b-1][a-1] = c;
}
cout << dijstra(n,0,n-1) << endl;
}
return 0;
}