并查集

 

HDU 1856 More is better

Problem Description Mr Wang wants some boys to help him with a project. Because the project is rather complex, 
the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang’s selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.

 

Input The first line of the input contains an integer n (0 ≤ n ≤ 100 000) – the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)  

Output The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep. 

 

Sample Input

4 1 2 3 4 5 6 1 6 4 1 2 3 4 5 6 7 8  

Sample Output

4 2
Hint A and B are friends(direct or indirect), B and C are friends(direct or indirect), then A and C are also friends(indirect). In the first sample {1,2,5,6} is the result. In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers.

思路:并查集入门题。设定一个根朋友,其他朋友如果是此根的朋友,则标记一下。所以代码分为两部分:查找和合并。查找就是如果得到某个数,那么找到这个数的根朋友。合并就是某一个的朋友被输入时,将其标记,并在根处计数。

代码:

#include<cstdio>
#include<cstring>
int father[10000000], num[10000000];
int find(int a)//查找
{
	if (a != father[a])
		father[a] = find(father[a]);
	return father[a];
}
void merge(int a, int b)//合并
{
	int p = find(a);
	int q = find(b);
	if (p != q)
	{
		father[q] = p;
		num[p] += num[q];
	}
}
int main()
{
	int i, j, n, a, b, max;
	while (scanf("%d", &n) != EOF)
	{
		for (i = 0;i < 10000000;i++)
		{
			father[i] = i;
			num[i] = 1;
		}
		while (n--)
		{
			scanf("%d%d", &a, &b);
			merge(a, b);
		}
		for (i = 0, max = 0;i < 10000000;i++)
			if (num[i]>max)
				max = num[i];
		printf("%d\n", max);
	}
	return 0;
}

点赞