Anagram --- 哈希算法

Time Limit: 1000MS
Memory Limit: 10000K
Total Submissions: 17711
Accepted: 7213

Description

You are to write a program that has to generate all possible words from a given set of letters. 
Example: Given the word “abc”, your program should – by exploring all different combination of the three letters – output the words “abc”, “acb”, “bac”, “bca”, “cab” and “cba”. 
In the word taken from the input file, some letters may appear more than once. For a given word, your program should not produce the same word more than once, and the words should be output in alphabetically ascending order. 

Input

The input consists of several words. The first line contains a number giving the number of words to follow. Each following line contains one word. A word consists of uppercase or lowercase letters from A to Z. Uppercase and lowercase letters are to be considered different. The length of each word is less than 13.

Output

For each word in the input, the output should contain all different words that can be generated with the letters of the given word. The words generated from the same input word should be output in alphabetically ascending order. An upper case letter goes before the corresponding lower case letter.

Sample Input

3 aAb abc acba 

Sample Output

Aab Aba aAb abA bAa baA abc acb bac bca cab cba aabc aacb abac abca acab acba baac baca bcaa caab caba cbaa 

Hint

An upper case letter goes before the corresponding lower case letter. 
So the right order of letters is ‘A'<‘a'<‘B'<‘b'<…<‘Z'<‘z’.

Source

Southwestern European Regional Contest 1995


解题分析:

这里用的是哈希算法,对应每一个字母都有一个映射关系。


代码:

#include<iostream>
#include<algorithm>
#include<string.h>
#include<stdio.h>
using namespace std;

int main()
{
    int n;
    cin>>n;
    while(n–)
    {

        char str[20];
        int hash[20];
        cin>>str;
        int len=strlen(str),l=1;
        for(int i=0;i<len;++i)
        {
            l*=(i+1);
            if(str[i]<=’Z’)
            {
                hash[i]=(str[i]+32)*2-1;
            }
            else
                hash[i]=str[i]*2;
        }
        sort(hash,hash+len);
        //sort(str,str+len);
      //  cout<<str;

        do
        {
            for(int j=0;j<len;++j)
            {
                if(hash[j]%2==0)
                    printf(“%c”,hash[j]/2);
                else
                    printf(“%c”,(hash[j]+1)/2-32 );
            }

            cout<<endl;

        }
         while(next_permutation(hash,hash+len));
    }
}

    原文作者:哈希算法
    原文地址: https://blog.csdn.net/u012965373/article/details/40018477
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞