Wooden Sticks
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 21183 Accepted Submission(s): 8546
Problem Description There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:
(a) The setup time for the first wooden stick is 1 minute.
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l’ and weight w’ if l<=l’ and w<=w’. Otherwise, it will need 1 minute for setup.
You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).
Input The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, …, ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.
Output The output should contain the minimum setup time in minutes, one per line.
Sample Input
3 5 4 9 5 2 2 1 3 5 1 4 3 2 2 1 1 2 2 3 1 3 2 2 3 1
Sample Output
2 1 3
题意:给你n个棍子,和他们的重量W高度h求最小准备时间。第一根木棍的准备时间为1分钟。往后如果W<=W’,H<=H’的准备时间为0分钟,反之为1分钟。
思路:先按照W对他们进行排序,以后按照H从上往下找比他大的
#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
struct node
{
int x,y;
}a[5001];
int vis[5001];
int cmp(node b,node c )
{
return b.x<=c.x;
}
int main()
{
int t;
cin>>t;
for(int i=1;i<=t;i++)
{
int n;
cin>>n;
for(int j=0;j<n;j++)
{
cin>>a[j].x>>a[j].y;
}
sort(a,a+n,cmp);
int s=0;
memset(vis,0,sizeof(vis));
for(int j=0;j<n;j++)
{
int p=j;
if(!vis[j])
{
vis[j]=1;
for(int k=j+1;k<n; k++)
{
if(!vis[k]&&a[p].y<=a[k].y)
{
vis[k]=1;
p=k;
continue;
}
}
s++;
}
}
cout<<s<<endl;
}
return 0;
}