Highways
Description
The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has no public highways. So the traffic is difficult in Flatopia. The Flatopian government is aware of this problem. They’re planning to build some highways so that it will be possible to drive between any pair of towns without leaving the highway system.
Flatopian towns are numbered from 1 to N. Each highway connects exactly two towns. All highways follow straight lines. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town that is located at the end of both highways.
The Flatopian government wants to minimize the length of the longest highway to be built. However, they want to guarantee that every town is highway-reachable from every other town.
Input
The first line of input is an integer T, which tells how many test cases followed.
The first line of each case is an integer N (3 <= N <= 500), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 65536]) between village i and village j. There is an empty line after each test case.
Output
For each test case, you should output a line contains an integer, which is the length of the longest road to be built such that all the villages are connected, and this value is minimum.
Sample Input
1 3 0 990 692 990 0 179 692 179 0
Sample Output
692
Hint
Huge input,scanf is recommended.
题意:给定一些地点和连通他们可以修的公路,求最小生成树的最大边
#include<iostream>
#include<algorithm>
using namespace std;
const int maxn = 505;
int fa[maxn], N, e;
struct Edge {
int u, v, len;
Edge() {}
Edge(int u, int v, int len) :u(u), v(v), len(len) {}
bool operator<(const Edge& other)const
{
return len < other.len;
}
}edges[maxn*maxn];
void addedge(int u, int v, int len)
{
edges[e++] = Edge(u, v, len);
}
void make()
{
for (int i = 1; i <= N; i++)
fa[i] = i;
}
int find(int x)
{
if (x != fa[x])
fa[x] = find(fa[x]);
return fa[x];
}
int kruskal()
{
int ans = 0, m = 0;
make();
sort(edges, edges + e);//边升序排列
for (int i = 0; i < e; i++)
{
int fu, fv;
fu = find(edges[i].u); fv = find(edges[i].v);
if (fu == fv) continue;//连通则跳过
fa[fu] = fv; //合并两点
ans = edges[i].len;//记录当前最大边
m++;//边计数
if (m == N - 1) break;
}
if (m < N - 1) return -1;
else return ans;
}
int main()
{
int T;
cin >> T;
while (T--)
{
cin >> N;
int len; e = 0;
for (int i = 1; i <= N; i++)
for (int j = 1; j <= N; j++)
{
scanf("%d", &len);
addedge(i, j, len);
}
cout << kruskal() << endl;
}
return 0;
}