poj3061----二分搜索的应用

Subsequence
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 15365 Accepted: 6496
Description

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.
Input

The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.
Output

For each the case the program has to print the result on separate line of the output file.if no answer, print 0.
Sample Input

2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5
Sample Output

2
3
解题思想:使用二分搜索不断寻找满足条件的子序列长度,就是一个使用二分搜索求满足条件的最小值的过程。

#include <iostream>
using namespace std;
const int MAX_N = 100000;
int number[MAX_N];
int sum[MAX_N];
bool judge(int len,int N,int S){
    bool res = false;
    for(int endPos = len - 1;endPos < N;endPos++){
        if(endPos == len - 1){
            if(sum[endPos] >= S){
                res = true;
                break;
            }
        }else if(sum[endPos] - sum[endPos - len] >= S){
            res = true;
            break;
        }
    }
    return res;
}
int binary_search(int N,int S){
    if(sum[N - 1] < S){
        return 0;
    }
    int lb = 0;
    int ub = N;
    while(lb <= ub){
        int mid = (lb + ub) / 2;
        if(judge(mid,N,S)){
            ub = mid - 1;
        }else{
            lb = mid + 1;
        }
    }
    return lb;
}
int main() {
    int test_num;
    int N,S;
    cin>>test_num;
    for(int i = 0;i < test_num;i++){
        cin>>N;
        cin>>S;
        for(int j = 0;j < N;j++){
            cin>>number[j];
            if(0 == j){
                sum[0] = number[j];
            }else{
                sum[j] = sum[j - 1] + number[j];
            }
        }
        cout<<binary_search(N,S)<<endl;
    }
    return 0;
}
点赞