CODEVS 1039 数的划分(划分型DP)

1039 数的划分

 

2001年NOIP全国联赛提高组

 时间限制: 1 s
 空间限制: 128000 KB
 题目等级 : 黄金 Gold
题解


题目描述 Description

将整数n分成k份,且每份不能为空,任意两种划分方案不能相同(不考虑顺序)。
例如:n=7,k=3,下面三种划分方案被认为是相同的。
1 1 5

1 5 1

5 1 1
问有多少种不同的分法。

输入描述 Input Description

输入:n,k (6<n<=200,2<=k<=6)

输出描述 Output Description

输出:一个整数,即不同的分法。

样例输入 Sample Input

 7 3

样例输出 Sample Output

4

数据范围及提示 Data Size & Hint

 {四种分法为:1,1,5;1,2,4;1,3,3;2,2,3;}

分类标签 Tags 点此展开 

#include <iostream>
#include <algorithm>
#include <string.h>
#include <stdio.h>
#include <math.h>
using namespace std;
long long dp[7][207];

int main(){
	
	int n,k;
	scanf("%d %d",&n,&k);
	dp[0][0]=1;
	for(int i=1;i<=k;i++){
		for(int j=1;j<=n;j++){
			dp[i][j]=dp[i][j-i]+dp[i-1][j-1];
		}
	}
	printf("%lld\n",dp[k][n]);
	return 0;
}
点赞