hdu1157Who's in the Middle

Who’s in the Middle

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9026    Accepted Submission(s): 4339

Problem Description FJ is surveying his herd to find the most average cow. He wants to know how much milk this ‘median’ cow gives: half of the cows give as much or more than the median; half give as much or less.

Given an odd number of cows N (1 <= N < 10,000) and their milk output (1..1,000,000), find the median amount of milk given such that at least half the cows give the same amount of milk or more and at least half give the same or less.

 

Input * Line 1: A single integer N

* Lines 2..N+1: Each line contains a single integer that is the milk output of one cow.

 

Output * Line 1: A single integer that is the median milk output.

 

Sample Input

5 2 4 1 3 5  

Sample Output

3
Hint INPUT DETAILS: Five cows with milk outputs of 1..5 OUTPUT DETAILS: 1 and 2 are below 3; 4 and 5 are above 3.
 

Source
USACO 2004 November     answer1:

#include<cstdio>
#include<algorithm>
using namespace std;
int main()
{
    int a[10005],n,i;
    while(scanf("%d",&n)!=EOF)
    {
        for(i=0;i<n;i++)
            scanf("%d",&a[i]);
        sort(a,a+n);
        printf("%d\n",a[n/2]);
    }
    return 0;
}
 

answer2:

#include"algorithm"
#include"stdio.h"
#include"iostream"
using namespace std;
int main(int argc, char* argv[])
{
    int n,a[10005],i;
    //while(scanf("%d",&n)!=EOF)
    while(cin>>n!=NULL)
    {
        for(i=0;i<n;i++)
        {
            cin>>a[i];
        }
        sort(a,a+n);
        cout<<a[n/2]<<endl;
    }
    return 0;
}
点赞