NYIST 708 ones

ones

时间限制:
1000 ms  |  内存限制:
65535 KB 难度:
3

描述
Given a positive integer N (0<=N<=10000), you are to find an expression equals to N using only 1,+,*,(,). 1 should not appear continuously, i.e. 11+1 is not allowed.

输入
There are multiple test cases. Each case contains only one line containing a integer N
输出
For each case, output the minimal number of 1s you need to get N.
样例输入
2
10
样例输出
2
7
#include <stdio.h>
//a[n]表示要生成n,最少需要的1的个数
//a[n]=min(a[k]+a[n-k], a[t]+a[n/t])
//其中,t为n的因子
int a[10001];

int main()
{
    int n;
    a[1]=1;
    for(int i=2; i<=10000; i++)
    {
        int b=1, e=i-1, min=100000;
        while(b<=e)
        {
            int t=a[b++]+a[e--];
            if(t<min)min=t;
        }
        b=2, e=i/2;
        while(b<=e)
        {
            if(i%b==0)
            {
                e=i/b;
                int t=a[b]+a[e];
                if(t<min)min=t;
            }
            ++b, --e;
        }
        a[i]=min;
    }
    while(scanf("%d", &n)==1)
        printf("%d\n", a[n]);
    return 0;
}

点赞