基础的深度优先搜索题目
通过对每一个位置的上下左右位置进行递归搜索。
题目描述:
Red and Black
Time Limit: 1000MS | Memory Limit: 30000K | |
Total Submissions: 31159 | Accepted: 17006 |
Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can’t move on red tiles, he can move only on black tiles.
Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.
There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.
‘.’ – a black tile
‘#’ – a red tile
‘@’ – a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.
Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
Sample Input
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#[email protected]#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### [email protected] ###.### ..#.#.. ..#.#.. 0 0
Sample Output
45
59
6
13
#include<iostream>
#include<algorithm>
#include<fstream>
#include<string>
using namespace std;
void solve();
void dfs(int row, int col);
int result = 0;
string grid[10001];
int n=-1, m=-1;
int main(){
while (true){
cin >> n >> m;
if (n == 0 && m == 0)break;
for (int i = 0; i < m; i++)
grid[i] = "";
for (int i = 0; i < m; i++)
cin >> grid[i];
result = 0;
solve();
cout << result << endl;
}
return 0;
}
void solve(){
int s_row=0, s_col=0;
bool isfind = false;
for (int i = 0; i < m; i++)
{
for (int j = 0; j < n;j++){
if (grid[i][j] == '@'){
s_row = i;
s_col = j;
isfind = true;
break;
}
if (isfind)
break;
}
}
dfs(s_row, s_col);
return;
}
void dfs(int row, int col){
result++;
int x, y;
grid[row][col]='#';
// int x, y;
for (int dy=-1;dy<=1;dy++)
for (int dx = -1; dx <= 1; dx++){
for (int dy = -1; dy <= 1; dy++){
//if x,y int the grid
x=row+ dx;
y=col+dy;
if ((dx==0||dy==0)&&x>= 0 && x<m&&y>=0 && y < n&&grid[x][y]=='.')
dfs(x, y);
}
}
return;
}