hdu-3342 拓扑排序java

Legal or Not

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 9478    Accepted Submission(s): 4422

Problem Description ACM-DIY is a large QQ group where many excellent acmers get together. It is so harmonious that just like a big family. Every day,many “holy cows” like HH, hh, AC, ZT, lcc, BF, Qinz and so on chat on-line to exchange their ideas. When someone has questions, many warm-hearted cows like Lost will come to help. Then the one being helped will call Lost “master”, and Lost will have a nice “prentice”. By and by, there are many pairs of “master and prentice”. But then problem occurs: there are too many masters and too many prentices, how can we know whether it is legal or not?

We all know a master can have many prentices and a prentice may have a lot of masters too, it’s legal. Nevertheless,some cows are not so honest, they hold illegal relationship. Take HH and 3xian for instant, HH is 3xian’s master and, at the same time, 3xian is HH’s master,which is quite illegal! To avoid this,please help us to judge whether their relationship is legal or not. 

Please note that the “master and prentice” relation is transitive. It means that if A is B’s master ans B is C’s master, then A is C’s master.  

Input The input consists of several test cases. For each case, the first line contains two integers, N (members to be tested) and M (relationships to be tested)(2 <= N, M <= 100). Then M lines follow, each contains a pair of (x, y) which means x is y’s master and y is x’s prentice. The input is terminated by N = 0.

TO MAKE IT SIMPLE, we give every one a number (0, 1, 2,…, N-1). We use their numbers instead of their names.  

Output For each test case, print in one line the judgement of the messy relationship.

If it is legal, output “YES”, otherwise “NO”.  

Sample Input

3 2 0 1 1 2 2 2 0 1 1 0 0 0  

Sample Output

YES NO

package 拓扑排序;

import java.util.*;

public class Main {
	static int num_person;
	static int num;
	static int[][] graph;
	static int[] enter;
	static Scanner sc = new Scanner(System.in);

	public static void main(String[] args) {
		while (sc.hasNext()) {
			num_person = sc.nextInt();
			num = sc.nextInt();
			if (num == 0 && num_person == 0)
				break;
			else {
				init();
				tofoSort();
			}
		}
	}
	public static void init() {
		graph=new int[num_person][num_person];
		enter=new int[num_person];
		for(int i=0;i<num;i++) {
			int from=sc.nextInt();
			int to=sc.nextInt();
			if(graph[from][to]==0) {
				graph[from][to]=1;
				enter[to]++;
			}
		}
	}
	public static void tofoSort() {
		for(int i=0;i<num_person;i++) {
			int k=-1;
			for(int j=0;j<num_person;j++) {
				if(enter[j]==0) {
					k=j;
					break;
				}
			}
			if(k==-1) {
				System.out.println("NO");
				return;
			}
			else {
				enter[k]=-1;
				for(int j=0;j<num_person;j++) {
					if(graph[k][j]==1) {
						enter[j]--;
						graph[k][j]=0;
					}
				}
			}
		}
		System.out.println("YES");
	}
}

 

点赞