Time Limit: 3000MS | Memory Limit: 65536KB | 64bit IO Format: %I64d & %I64u |
Description
Given two strings a and b we define a*b to be their concatenation. For example, if a = “abc” and b = “def” then a*b = “abcdef”. If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = “” (the empty string) and a^(n+1) = a*(a^n).
Input
Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.
Output
For each s you should print the largest n such that s = a^n for some string a.
Sample Input
abcd aaaa ababab .
Sample Output
1 4
3
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#define maxn 1000005
using namespace std;
char str[maxn];
int next[maxn],len;
void get_next();
int main()
{
while(~scanf("%s",str)&&strcmp(str,"."))
{
len=strlen(str);
get_next();
int ans=1;
if(len%(len-next[len])==0)
ans=len/(len-next[len]);
printf("%d\n",ans);
}
}
void get_next()
{
int i=0,j=-1;
next[0]=-1;
while(i<len)
{
if(j==-1||str[i]==str[j])
{
i++;
j++;
if(str[i]!=str[j])//仅仅满足j==-1
next[i]=j;
else
next[i]=next[j];//仅仅满足str[i]==str[j]
}
else
j=next[j];
}
}
由于我们知道next数组中存的是一个位置(假设next[j]的值为k,对应的字符串为M,如果k>0,那么M[0….k-1]和M[j-k…..j-1]是相同的,并且0…k-1这个序列一定是最长的),比如a b c a b c d(next值:-1 0 0 0 1 2 3 ),由next[6]=3可知,M[0..2]=M[3..6],这就找到了循环节,于是我们思考从next数组作为切入点,来找到一种方法来求得循环节的个数。