HDU 4763 Theme Section(KMP)

Theme Section

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 944    Accepted Submission(s): 503

Problem Description It’s time for music! A lot of popular musicians are invited to join us in the music festival. Each of them will play one of their representative songs. To make the programs more interesting and challenging, the hosts are going to add some constraints to the rhythm of the songs, i.e., each song is required to have a ‘theme section’. The theme section shall be played at the beginning, the middle, and the end of each song. More specifically, given a theme section E, the song will be in the format of ‘EAEBE’, where section A and section B could have arbitrary number of notes. Note that there are 26 types of notes, denoted by lower case letters ‘a’ – ‘z’.

To get well prepared for the festival, the hosts want to know the maximum possible length of the theme section of each song. Can you help us?

 

Input The integer N in the first line denotes the total number of songs in the festival. Each of the following N lines consists of one string, indicating the notes of the i-th (1 <= i <= N) song. The length of the string will not exceed 10^6.  

Output There will be N lines in the output, where the i-th line denotes the maximum possible length of the theme section of the i-th song.

 

Sample Input

5 xy abc aaa aaaaba aaxoaaaaa  

Sample Output

0 0 1 1 2

题意:给定一个字符串,找出能构成”EAEBE”形式的字符串的E的最长长度。

思路:KMP,先对原串求出next数组,利用next数组,不断往前推,每次推的时候在中间看能不能找到一个匹配串即可。

代码:

#include <stdio.h>
#include <string.h>

const int N = 1000005;

int n, next[N], t;
char s[N], s2[N];

void get_next(char *seq, int m) {
	next[0] = -1;
	int j = next[0];
	for (int i = 1; i < m; i++) {
		while (j >= 0 && seq[i] != seq[j + 1]) j = next[j];
		if (seq[i] == seq[j + 1]) j++;
		next[i] = j;
	}
}

bool kmp(char *seq, char *seq1, int n, int m) {
	int j = next[0], ans = 0;
	for (int i = 0; i < n; i++) {
		while (j >= 0 && seq[i] != seq1[j + 1]) j = next[j];
		if (seq[i] == seq1[j + 1]) j++;
		if (j == m - 1) {
			return true;
		}
	}
	return false;
}

bool judge(int len) {
	if (len > n / 3) return false;
	for (int i = 0; i < len; i++)
		s2[i] = s[i];
	s2[len] = '\0';
	return kmp(s + len, s2, n - len * 2, len);
}

int main() {
	scanf("%d", &t);
	while (t--) {
		scanf("%s", s);
		n = strlen(s);
		get_next(s, n);
		int tmp = next[n - 1];
		while (1) {
			if (judge(tmp + 1)) {
				printf("%d\n", tmp + 1);
				break;
			}
			else {
				if (tmp == -1) {
					printf("0\n");
					break;
				}
				tmp = next[tmp];
			}
		}
	}
	return 0;
}
    原文作者:KMP算法
    原文地址: https://blog.csdn.net/accelerator_/article/details/21563699
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞