POJ2752 Seek the Name, Seek the Fame 【KMP】

Seek the Name, Seek the Fame

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 11602 Accepted: 5680

Description

The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative little cat works out an easy but fantastic algorithm: 

Step1. Connect the father’s name and the mother’s name, to a new string S. 

Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S). 

Example: Father=’ala’, Mother=’la’, we have S = ‘ala’+’la’ = ‘alala’. Potential prefix-suffix strings of S are {‘a’, ‘ala’, ‘alala’}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings of S? (He might thank you by giving your baby a name:) 

Input

The input contains a number of test cases. Each test case occupies a single line that contains the string S described above. 

Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000. 

Output

For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby’s name.

Sample Input

ababcababababcabab
aaaaa

Sample Output

2 4 9 18
1 2 3 4 5

题意:给定一个串,求它的子串的长度,子串满足既是主串的前缀,又是主串的后缀,将所有满足要求的子串长度按照升序输出。

题解:next数组的简单运用,(但是读懂题意用了好久啊。。)求出next数组后递归输出相应的后缀长度,len要单独输出。

#include <stdio.h>
#define maxn 400002

char str[maxn];
int next[maxn], len;

void getNext()
{
	int i = 0, j = -1;
	next[0] = -1;
	while(str[i]){
		if(j == -1 || str[i] == str[j]){
			++i; ++j;
			next[i] = j; //mode 1
		}else j = next[j];
	}
	len = i;
}

void getVal(int n)
{
	if(next[n] == 0) return;
	getVal(next[n]);
	printf("%d ", next[n]);
}

int main()
{
	//freopen("stdin.txt", "r", stdin);
	while(scanf("%s", str) == 1){
		getNext();
		getVal(len);
		printf("%d\n", len);
	}
	return 0;
}
    原文作者:KMP算法
    原文地址: https://blog.csdn.net/chang_mu/article/details/37930307
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞