hdoj 2594 Simpsons’ Hidden Talents 【KMP】【求串的最长公共前缀后缀】

Simpsons’ Hidden Talents


Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 4597    Accepted Submission(s): 1671

Problem Description Homer: Marge, I just figured out a way to discover some of the talents we weren’t aware we had.

Marge: Yeah, what is it?

Homer: Take me for example. I want to find out if I have a talent in politics, OK?

Marge: OK.

Homer: So I take some politician’s name, say Clinton, and try to find the length of the longest prefix

in Clinton’s name that is a suffix in my name. That’s how close I am to being a politician like Clinton

Marge: Why on earth choose the longest prefix that is a suffix???

Homer: Well, our talents are deeply hidden within ourselves, Marge.

Marge: So how close are you?

Homer: 0!

Marge: I’m not surprised.

Homer: But you know, you must have some real math talent hidden deep in you.

Marge: How come?

Homer: Riemann and Marjorie gives 3!!!

Marge: Who the heck is Riemann?

Homer: Never mind.

Write a program that, when given strings s1 and s2, finds the longest prefix of s1 that is a suffix of s2.  

Input Input consists of two lines. The first line contains s1 and the second line contains s2. You may assume all letters are in lowercase.  

Output Output consists of a single line that contains the longest string that is a prefix of s1 and a suffix of s2, followed by the length of that prefix. If the longest such string is the empty string, then the output should be 0.

The lengths of s1 and s2 will be at most 50000.  

Sample Input

clinton homer riemann marjorie  

Sample Output

0 rie 3  

题意:给你两个字符串s1、s2,让你找出最长的字符串 使得它既是s1的前缀又是s2的后缀。

分析:f[ i ]表示字符串中第i个字符(字符串下标是从0开始的)前面的字符串的最长公共前缀后缀。 

思路:连接两个字符串,求失配函数f[]。最后分类讨论f[len](len为连接后的新字符串长度),因为f[len]的值可能大于s1或者s2的长度。

AC代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
char s1[100100], s2[50100];
char ss[50100];
int f[100100];//注意数组大小
void getfail(char *P)
{
    int len = strlen(P);
    f[0] = f[1] = 0;
    for(int i = 1; i < len; i++)
    {
        int j = f[i];
        while(j && P[i] != P[j])
            j = f[j];
        f[i+1] = P[i]==P[j] ? j+1 : 0;
    }
}
int main()
{
    while(scanf("%s%s", s1, s2) != EOF)
    {
        int l1 = strlen(s1);
        int l2 = strlen(s2);
        strcpy(ss, s1);
        strcat(s1, s2);
        getfail(s1);
        int len = strlen(s1);
        if(f[len])
        {
            if(f[len] > min(l1, l2))//特殊情况
            {
                if(l1 < l2)//选取长度较小的串
                    printf("%s %d\n", ss ,l1);
                else
                    printf("%s %d\n", s2, l2);
            }
            else
            {
                for(int i = 0; i < f[len]; i++)
                    printf("%c", s1[i]);
                printf(" %d\n", f[len]);
            }
        }
        else
            printf("0\n");
    }
    return 0;
}
    原文作者:KMP算法
    原文地址: https://blog.csdn.net/chenzhenyu123456/article/details/47746457
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞