HDU2594 (kmp,求两字符串的前后缀相同长度最大,水题)

 

 

Homer: Marge, I just figured out a way to discover some of the talents we weren’t aware we had. 
Marge: Yeah, what is it? 
Homer: Take me for example. I want to find out if I have a talent in politics, OK? 
Marge: OK. 
Homer: So I take some politician’s name, say Clinton, and try to find the length of the longest prefix 
in Clinton’s name that is a suffix in my name. That’s how close I am to being a politician like Clinton 
Marge: Why on earth choose the longest prefix that is a suffix??? 
Homer: Well, our talents are deeply hidden within ourselves, Marge. 
Marge: So how close are you? 
Homer: 0! 
Marge: I’m not surprised. 
Homer: But you know, you must have some real math talent hidden deep in you. 
Marge: How come? 
Homer: Riemann and Marjorie gives 3!!! 
Marge: Who the heck is Riemann? 
Homer: Never mind. 
Write a program that, when given strings s1 and s2, finds the longest prefix of s1 that is a suffix of s2.

Input

Input consists of two lines. The first line contains s1 and the second line contains s2. You may assume all letters are in lowercase.

Output

Output consists of a single line that contains the longest string that is a prefix of s1 and a suffix of s2, followed by the length of that prefix. If the longest such string is the empty string, then the output should be 0. 
The lengths of s1 and s2 will be at most 50000.

Sample Input

clinton
homer
riemann
marjorie

Sample Output

0
rie 3

题意:

给你两个字符串,让你求一个字符串 这个字符串满足是第二个字符串的后缀,且是第一个字符串的前缀,找出满足情况的最长的字符串

思路:

1.可以将两个字符串连接起来 用next数组的意义来做,找出最后下标的最大匹配即可

2.利用kmp的意义,如果第二个字符串的前j个字符的最大匹配为k,那么即为j-1的字符串的最大匹配且第j个字符与匹配的第k个字符相等即可.

//第二种方法
#include<stdio.h>
#include<cstring>
#include<cstdlib>
#include<string>
#include<algorithm>
using namespace std;
const int maxn=5e4+7;
int net[maxn],res[maxn];
char p[maxn],str[maxn];
void get_next(char *p,int *net)
{
    int lp=strlen(p);
    int j=0,k=-1;
    net[0]=-1;
    net[++j]=++k;
    while(j<lp)
    {
        if(k==-1||p[j]==p[k])
        {
            net[++j]=++k;
        }
        else
            k=net[k];
    }
}
void Solve(char *p,char *str)//指针str的后缀是其p的前缀
{
    int i=0,k=0;
    get_next(p,net);
    int ls=strlen(str);
    // res[j]=k代表str前j个字符的最大匹配个数为k(字符串s的前k个)
    while(i<ls)
    {
        if(k==-1||str[i]==p[k])//i k表示 正在匹配的字符
        {
            ++i;
            ++k;
            res[i]=k;
        }
        else
            k=net[k];
    }
    int ans=res[ls];
    if(!ans)
        printf("0\n");
    else
    {
        p[ans]='\0';
        printf("%s %d\n",p,ans);
    }
}
int main()
{
    while(~scanf("%s %s",p,str))
    {
        Solve(p,str);
    }
}

 

 

 

    原文作者:KMP算法
    原文地址: https://blog.csdn.net/Dch19990825/article/details/83822343
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞