(KMP 1.2)hdu 1686 Oulipo(计算模式串在文本串中出现的次数)

题目:

Oulipo

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5985    Accepted Submission(s): 2404

Problem Description The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter ‘e’. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive ‘T’s is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {‘A’, ‘B’, ‘C’, …, ‘Z’} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

 

Input The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).

One line with the text T, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with |W| ≤ |T| ≤ 1,000,000.

 

Output For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

 

Sample Input

3 BAPC BAPC AZA AZAZAZA VERDI AVERDXIVYERDIAN  

Sample Output

1 3 0  

Source
华东区大学生程序设计邀请赛_热身赛  

Recommend lcy   |   We have carefully selected several similar problems for you:  
1358 
3336 
3746 
2203 
3068 


题目分析:

           KMP,简单题。


代码如下:

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>

using namespace std;

const int maxn = 1000001;


char text[maxn];//文本串
char pattern[maxn];//模式串
int nnext[maxn];//next数组.直接起next可能会跟系统中预定的重名

/*O(m)的时间求next数组*/
void get_next() {
	int patternLen = strlen(pattern);//计算模式串的长度

	nnext[0] = nnext[1] = 0;
	for (int i = 1; i < patternLen; i++) {
		int j = nnext[i];
		while (j && pattern[i] != pattern[j]){
			j = nnext[j];
		}
		nnext[i + 1] = pattern[i] == pattern[j] ? j + 1 : 0;
	}
}

/*o(n)的时间进行匹配
 *
 * 返回第一次匹配的位置
 */
int kmp() {

	int ans = 0;//计算模式串在文本串中出现的次数

	int textLen = strlen(text);//计算文本串的长度
	int patternLen = strlen(pattern);//计算模式串的长度

	int j = 0;/*初始化在模式串的第一个位置*/
	for (int i = 0; i < textLen; i++) {/*遍历整个文本串*/
		while (j && pattern[j] != text[i]){/*顺着失配边走,直到可以匹配,最坏得到情况是j = 0*/
			j = nnext[j];
		}
		if (pattern[j] == text[i]){/*如果匹配成功继续下一个位置*/
			j++;
		}
		if (j == patternLen) {
			ans++;//计算pattern在text中出现的次数..
		}
	}

	return ans;
}

int main() {
	int t;
	scanf("%d", &t);
	while (t--) {
		scanf("%s%s", pattern, text);
		get_next();
		printf("%d\n", kmp());
	}

	return 0;
}



    原文作者:KMP算法
    原文地址: https://blog.csdn.net/hjd_love_zzt/article/details/45111985
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞