Oulipo
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 36896 | Accepted: 14896 |
Description
The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter ‘e’. He was a member of the Oulipo group. A quote from the book:
Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…
Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive ‘T’s is not unusual. And they never use spaces.
So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {‘A’, ‘B’, ‘C’, …, ‘Z’} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.
Input
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:
- One line with the word W, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
- One line with the text T, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with |W| ≤ |T| ≤ 1,000,000.
Output
For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.
Sample Input
3 BAPC BAPC AZA AZAZAZA VERDI AVERDXIVYERDIAN
Sample Output
1 3 0
Source
原题链接:http://poj.org/problem?id=3461
题意:输入两个字符串,问第一个字符串在第二个字符串中的出现次数。(可重叠)。
直接套模板:
AC代码:
#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;
const int maxn=100000+5;
char p[maxn];
char s[maxn*100];
int lenp,lens;
int Next[maxn];
void getNext()
{
int i=0,j=-1;
memset(Next,0,sizeof(Next));
Next[0]=-1;
while(i<lenp)
{
if(j==-1||p[i]==p[j])
{
i++,j++;
Next[i]=j;
}
else
j=Next[j];
}
}
int KMP()
{
int i=0,j=0;
int ans=0;
while(i<lens)
{
if(j==-1||s[i]==p[j])
{
i++,j++;
}
else
j=Next[j];
if(j==lenp)
{
ans++;
j=Next[j];
//若两个不同的匹配没有交集则j=0,
//若存在交集则j=next[j];
}
}
return ans;
}
int main()
{
int T;
cin>>T;
while(T--)
{
cin>>p>>s;
lens=strlen(s);
lenp=strlen(p);
getNext();
cout<<KMP()<<endl;
}
return 0;
}
尊重原创,转载请注明出处:http://blog.csdn.net/hurmishine