ACM-KMP之Period——hdu1358

Period

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 2401 Accepted Submission(s): 1190

Problem Description
For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as AK , that is A concatenated K times, for some string A. Of course, we also want to know the period K.

Input
The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it.

Output
For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.

Sample Input
3
aaa
12
aabaabaabaab
0

Sample Output
Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3

12 4


这道题也是KMP算法,next数组的活用,这个官方用语叫 循环节,

题意应该不难理解,这里就不翻译了,多注意一下格式啊。。。

对于这个循环节就是两个公式,

在i位置可以判断0~i-1的循环:

如果i%(i-next[i])==0 那么就有循环

循环次数为 i/(i-next[i])

循环长度为 i-next[i]


如果看不懂,可以看详细版的:http://www.cnblogs.com/jackge/archive/2013/01/05/2846006.html

不懂KMP的next数组怎么求可以看我的另一篇  http://blog.csdn.net/lttree/article/details/20733857

代码在此:

#include <stdio.h>
#include <string.h>
using namespace std;
char c[1000001];
int next[1000001];	// 注意数组大小哈~。~
int len;

// 求next数组
void Get_next()
{
    int i,j;
	next[0]=-1;
	i=0;
	j=-1;
	while(i<len)
	{
	    if(j==-1 || c[i]==c[j])
	    {
	       next[++i]=++j;
	    }
	    else    j=next[j];
	}
}

void show(void)
{
    int i,n;
	// 如果c[i-1]的话要跳过的,详情可以看我下面链接
    for(i=2;c[i-1];++i)
    {
        n=i-next[i];
        if(i%n==0 && i/n>1)
        {
            printf("%d %d\n",i,i/n);
        }
    }
    return;
}

int main()
{
    int num=1;
    while(scanf("%d",&len)!=EOF)
    {
        if(len==0)    break;
	    memset(next,0,sizeof(next));
	    scanf("%s",c);

        Get_next();

        printf("Test case #%d\n",num++);
        show();
		// 注意格式啊!这个换行又坑了我一次WA
        printf("\n");
    }
	return 0;
}

    原文作者:KMP算法
    原文地址: https://blog.csdn.net/lttree/article/details/20732385
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞