Oulipo 哈希代替KMP再做字符串处理

Oulipo

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 39845 Accepted: 16034

Description

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter ‘e’. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive ‘T’s is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {‘A’, ‘B’, ‘C’, …, ‘Z’} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

  • One line with the word W, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
  • One line with the text T, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with |W| ≤ |T| ≤ 1,000,000.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input

3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

Sample Output

1
3
0

哈希的hash数组存储是从后往前,例如sub串是123,str串是12354,那么hash0 = 12354,(进度暂时为1)这里的下标是串到从最大到结束的结束下标,即hash0其实存的是一个5位数的数值,hash1=45,hash2=453,…..

sub_Max就是sub串的总键值(原串就是key)

123

12354,查找即hash[0] – hash[3]*p[L] = 12354 – 45*1000 =123,进制是跳一位的,刚好下标也是从0开始

这道题注意进制选对,26个字母,开始选的30,WA,27AC了。这里可能冲突有点问题,但是一般改成1e6+7啥的试试,一般错不了

#include <iostream>
#include <cstring>
#include <cstdio>

using namespace std;
typedef unsigned long long ll;
const int base = 27;//
const int maxn = 1e6+10;

char sub[maxn],str[maxn];
ll p[maxn];//肯定要用long,int不够存
ll hash[maxn];

int main()
{
//    freopen("in.txt","r",stdin);
    int T,i;
    cin>>T;
    p[0]=1;
    for(i=1; i<maxn; i++)
        p[i]=p[i-1]*base;//进位,也是反向数的,比如12354,123是1000

    while(T--)
    {
        memset(sub,0,sizeof(sub));
        memset(str,0,sizeof(str));
        scanf("%s",sub);
        scanf("%s",str);
        int L = strlen(sub);
        int n = strlen(str);
        ll sub_Max=0;
        for(i=L-1; i>=0; i--)
        {
            sub_Max=sub_Max*base+sub[i]; //反向赋值
        }

        hash[n]=0;
        for(i=n-1; i>=0; i--)
        {
            hash[i]=hash[i+1]*base+str[i];//反向赋值,便于取前面字符串
        }

        int ans=0;
        for(i=0; i<=n-L; i++)   //从0开始就是(i<=n-L),从1开始就是(i<n-L+1)
        {
//            cout<<sub_Max<<" "<<hash[i]<<" "<<hash[i+L]<<" "<<p[L];
            if(sub_Max==hash[i]-hash[i+L]*p[L])
                ans++;
        }
        printf("%d\n",ans);
    }
    return 0;
}

    原文作者:KMP算法
    原文地址: https://blog.csdn.net/major_zhang/article/details/70233518
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞