KMP练手 - 模板

实验三 KMP算法

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 1473 Accepted: 751

Description

给定一个源串s和n个子串stri。判断stri是否是s的子串。

Input

输入数据有多组,对于每组测试数据 第一行源串S(S长度小于100000),第二行一个整数n, 表示下面有n个查询,每行一个字符串str。

Output

若str是S的子串,输出 yes 否则输出 no

Sample Input

acmicpczjnuduzongfei

3

icpc

du

liu

Sample Output

yes

yes

no

Hint

因为串的长度比较长,超过256,因此本题的串不适合用定长顺序存储表示来存储串,SString的长度放在第一个元素,这个元素占一个字节,最大255.

题解:

        题目非常简单,就是KMP的裸题,直接套模板即可,需要注意的是,如果题目出现了一些莫名其妙的编译错误,那么就要注意了,可能是自己定义的变量名与系统名冲突了,例如Next和next,就只能使用Next,如果用next作为数组名会CE的。

#include <iostream>
#include <cstring>
using namespace std;

const int MAXN = 1e5+7;
int Next[100007];
char str[MAXN],sub[MAXN];


void MakeNext(){
    int len = strlen(sub);
    Next[0] = 0;
    int k;
    for (int i = 1,k = 0;i < len;i ++){
        while (sub[k] != sub[i] && k > 0)
            k = Next[k-1];
        if (sub[k] == sub[i])
            k ++;
        Next[i] = k;
    }
}

int KMP(){
    MakeNext();
    int len1 = strlen(str);
    int len2 = strlen(sub);

    for (int i = 1,j = 0;i < len1;i ++){
        while (sub[j] != str[i] && j > 0)
            j = Next[j-1];
        if (sub[j] == str[i])
            j ++;
        if (j == len2) return i-j+1;
    }

    return -1;
}

int main()
{
    ios::sync_with_stdio(false);
    cin >> str;

    int n;
    cin >> n;
    while (n --){
        cin >> sub;
        if (KMP() != -1) cout << "yes" << endl;
        else             cout << "no"  << endl;

    }
}

    原文作者:KMP算法
    原文地址: https://blog.csdn.net/qq_40513946/article/details/79916934
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞