[kuangbin带你飞]专题十六 KMP

B – Oulipo
  HDU-1686

Oulipo

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 18359    Accepted Submission(s): 7223

Problem Description
The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter ‘e’. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive ‘T’s is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {‘A’, ‘B’, ‘C’, …, ‘Z’} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

 

Input
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).

One line with the text T, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with |W| ≤ |T| ≤ 1,000,000.

 

Output
For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

 

Sample Input

3BAPCBAPCAZAAZAZAZAVERDIAVERDXIVYERDIAN  

Sample Output

130

题解:

          输入两个字符串,让我们寻找其中在第一个字符串中第二个字符串出现了几次。水题,简单KMP。

#include <iostream>
#include <cstring>
using namespace std;

const int MAXN = (int)1e6+7;
char str[MAXN];
char sub[10007];
int Next[10007];

void MakeNext(){
    Next[0] = 0;
    int len = strlen(sub);
    for (int i = 1,k = 0;i < len;i ++){
        while (k > 0 && sub[k] != sub[i])
            k = Next[k-1];
        if (sub[k] == sub[i]) k ++;
        Next[i] = k;
    }
}

int KMP(){
    MakeNext();
    int ans = 0;
    int len1 = strlen(str);
    int len2 = strlen(sub);
    for (int i = 0,j = 0;i < len1;i ++){
        while (j > 0 && sub[j] != str[i])
            j = Next[j-1];
        if (sub[j] == str[i]) j ++;
        if (j == len2){
            j = Next[j-1];
            ans ++;
        }
    }
    return ans ;
}

int main()
{
    ios::sync_with_stdio(false);

    int T;
    cin >> T;
    while (T --){
        cin >> sub >> str;
        cout << KMP() << endl;
    }
}

    原文作者:KMP算法
    原文地址: https://blog.csdn.net/qq_40513946/article/details/79918824
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞