Number Sequence
Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 12603 Accepted Submission(s): 5735
Problem Description Given two sequences of numbers : a[1], a[2], …… , a[N], and b[1], b[2], …… , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], …… , a[K + M – 1] = b[M]. If there are more than one K exist, output the smallest one.
Input The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], …… , a[N]. The third line contains M integers which indicate b[1], b[2], …… , b[M]. All integers are in the range of [-1000000, 1000000].
Output For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
Sample Input
2 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 1 3 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 2 1
Sample Output
6 -1
Source
HDU 2007-Spring Programming Contest
给你两个窜、 求B窜匹配A窜时第一个数字在A窜里的下标。。。 KMP算法。搞了半天求Next【】数组的还不是很懂。。 先上代码。。。 以后再写myself的想法。
#include <cstdio>
#include <iostream>
#include <algorithm>
#include <vector>
#include <map>
#include <set>
#include <cmath>
#include <cstring>
#include <queue>
#include <stack>
#include <time.h>
using namespace std;
typedef long long ll;
#define mod 1e9+9
#define inf 0x7f7f7f7f
int a[1000005];
int b[10005];
int Next[10005];
int n,m;
void GetNext() //这个GetNext研究了一个晚上还是不太懂。。
{
int i,j;
i=0;
j=-1;
Next[0]=-1;
while(i<m)
{
if(j==-1 ||b[i]==b[j])
{
++i;
++j;
if(b[i]!=b[j])
Next[i]=j;
else
Next[i]=Next[j];
}
else
j=Next[j];
}
}
int kmp()
{
int i,j;
i=j=0;
while(i<n)
{
if(j==-1 ||a[i]==b[j])
{
++i;
++j;
if(j==m)
return i-m+1;
}
else
j=Next[j];
}
return -1;
}
int main()
{
int i,t;
cin>>t;
while(t--)
{
cin>>n>>m;
for(i=0;i<n;i++)
cin>>a[i];
for(i=0;i<m;i++)
cin>>b[i];
GetNext();
cout<<kmp()<<endl;
}
return 0;
}