POJ2752 Seek the Name, Seek the Fame 解题报告【字符串】【KMP】

Description
The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative little cat works out an easy but fantastic algorithm:
Step1. Connect the father’s name and the mother’s name, to a new string S.
Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S).
Example: Father=’ala’, Mother=’la’, we have S = ‘ala’+’la’ = ‘alala’. Potential prefix-suffix strings of S are {‘a’, ‘ala’, ‘alala’}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings of S? (He might thank you by giving your baby a name:)
Input
The input contains a number of test cases. Each test case occupies a single line that contains the string S described above.
Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000.
Output
For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby’s name.
Sample Input
ababcababababcabab
aaaaa
Sample Output
2 4 9 18
1 2 3 4 5
解题报告
这个题叫我们求即使前缀又是后缀的字串的长度。显然就让人想到了next数组。next[i]表示的是前i-1位中相等的前后缀串的长度。显然这里我们不停地用i=next[i],再看第i位和最后一位相等与否就行了。
代码如下:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int N=400000;
char s[N+5];
int next[N+5],len;
int ans[N+5],num;
void getnext()
{
    int i=0,j=-1;
    next[0]=-1;
    while(i<len)
    {
        if(j==-1||s[i]==s[j])
        {
            i++;
            j++;
            next[i]=j;
        }
        else j=next[j];
    }
}
int main()
{
    while(scanf("%s",s)!=EOF)
    {
        num=0;
        len=strlen(s);
        getnext();
        int t=next[len-1];
        while(t!=-1)
        {
            if(s[t]==s[len-1])ans[++num]=t+1;
            t=next[t];
        }
        for(int i=num;i>=1;i--)printf("%d ",ans[i]);
        printf("%d\n",len);
    }
    return 0;
}
    原文作者:KMP算法
    原文地址: https://blog.csdn.net/theljt/article/details/76222419
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞